CVE-2026-26989 LibreNMS has Stored XSS in Alert Rule

Medium 4.3 Published Updated

Administrators can inject malicious scripts into Alert Rules, leading to code execution in other users' browsers.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-26989?

CVE-2026-26989 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 20 Feb 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below are affected by a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Rules workflow. An attacker with administrative privileges can inject malicious scripts that execute in the browser context of any user who accesses the Alert Rules page. This issue has been fixed in version 26.2.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-26989?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.

PackageAffectedFixed in
librenms/librenms PackagistAll versions26.2.0
librenms/librenms PackagistAll versions26.2.0

Products include Librenms Librenms.

How do I fix CVE-2026-26989?

Upgrade librenms/librenms to 26.2.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-26989 being exploited?

There is no known exploitation of CVE-2026-26989 in the wild and no public exploit code.

All Librenms Librenms vulnerabilities

Sources

Also known as GHSA-6xmx-xr9p-58p7.

Is CVE-2026-26989 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free