# CVE-2026-26992: LibreNMS has Stored Cross-Site Scripting via unsanitized /port-groups name

> Attackers with admin privileges can inject malicious scripts via unsanitized port group names, leading to stored XSS attacks against other users.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-93fx-g747-695x

## What is CVE-2026-26992?

CVE-2026-26992 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 20 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. In versions 26.1.1 and below, the port group name is not sanitized, allowing attackers with admin privileges to perform Stored Cross-Site Scripting (XSS) attacks. When a user adds a port group, an HTTP POST request is sent to the Request-URI "/port-groups". The name of the newly created port group is stored in the value of the name parameter. After the port group is created, the entry is displayed along with relevant buttons such as Edit and Delete. This issue has been fixed in version 26.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-26992?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 26.2.0 |
| `librenms/librenms` | Packagist | All versions | 26.2.0 |

Products: Librenms Librenms.

## How do I fix CVE-2026-26992?

Upgrade librenms/librenms to 26.2.0 or later.

## Is CVE-2026-26992 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26992 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-26992 and fix it if it is affected.

What it is: CVE-2026-26992 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 20 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-26992 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 26.2.0
- librenms/librenms (Packagist): affected all versions; fixed in 26.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-26992/ (Markdown: https://insights.sbomify.com/CVE-2026-26992/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-26992
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-26992
- OSV: https://osv.dev/vulnerability/CVE-2026-26992

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-26992/
Summaries are generated and may contain mistakes; the official description above is the record.
