CVE-2026-26994 uTLS ServerHellos are accepted without checking TLS 1.3 downgrade canaries
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-26994?
CVE-2026-26994 is a medium-severity vulnerability in refraction-networking utls, published on 20 Feb 2026.
Official description
uTLS is a fork of crypto/tls, created to customize ClientHello for fingerprinting resistance while still using it for the handshake. In versions 1.6.7 and below, uTLS did not implement the TLS 1.3 downgrade protection mechanism specified in RFC 8446 Section 4.1.3 when using a uTLS ClientHello spec. This allowed an active network adversary to downgrade TLS 1.3 connections initiated by a uTLS client to a lower TLS version (e.g., TLS 1.2) by modifying the ClientHello message to exclude the SupportedVersions extension, causing the server to respond with a TLS 1.2 ServerHello (along with a downgrade canary in the ServerHello random field). Because uTLS did not check the downgrade canary in the ServerHello random field, clients would accept the downgraded connection without detecting the attack. This attack could also be used by an active network attacker to fingerprint uTLS connections. This issue has been fixed in version 1.7.0.
Weakness: CWE-693
Which versions are affected by CVE-2026-26994?
3 open source packages ship an affected version, including github.com/refraction-networking/utls. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/refraction-networking/utls Go | All versions | 1.7.0 |
github.com/refraction-networking/utls Go | All versions | 1.7.0 |
github.com/refraction-networking/utls Go | From 1.0.0 | 1.7.0 |
Products include Refraction-Networking Utls.
How do I fix CVE-2026-26994?
Upgrade github.com/refraction-networking/utls to 1.7.0 or later.
Is CVE-2026-26994 being exploited?
There is no known exploitation of CVE-2026-26994 in the wild and no public exploit code.
Other vulnerabilities in refraction-networking utls
Sources
Also known as DEBIAN-CVE-2026-26994, GHSA-pmc3-p9hx-jq96, GO-2025-3638, UBUNTU-CVE-2026-26994.