# CVE-2026-27004: OpenClaw session tool visibility hardening and Telegram webhook secret fallback

> In shared multi-user deployments, session tools may expose transcript content across peer sessions due to insufficient visibility scoping.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-6hf3-mhgc-cm65

## What is CVE-2026-27004?

CVE-2026-27004 is a medium-severity vulnerability in Openclaw Openclaw, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenClaw is a personal AI assistant. Prior to version 2026.2.15, in some shared-agent deployments, OpenClaw session tools (`sessions_list`, `sessions_history`, `sessions_send`) allowed broader session targeting than some operators intended. This is primarily a configuration/visibility-scoping issue in multi-user environments where peers are not equally trusted. In Telegram webhook mode, monitor startup also did not fall back to per-account `webhookSecret` when only the account-level secret was configured. In shared-agent, multi-user, less-trusted environments: session-tool access could expose transcript content across peer sessions. In single-agent or trusted environments, practical impact is limited. In Telegram webhook mode, account-level secret wiring could be missed unless an explicit monitor webhook secret override was provided. Version 2026.2.15 fixes the issue.

Weakness: CWE-346 (Origin Validation Error), CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-27004?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.15 |
| `openclaw` | npm | All versions | 2026.2.15 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-27004?

Upgrade openclaw to 2026.2.15 or later.

## Is CVE-2026-27004 being exploited?

There is no known exploitation of CVE-2026-27004 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27004 and fix it if it is affected.

What it is: CVE-2026-27004 is a medium-severity vulnerability in Openclaw Openclaw, published on 19 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27004 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.15
- openclaw (npm): affected all versions; fixed in 2026.2.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27004/ (Markdown: https://insights.sbomify.com/CVE-2026-27004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27004
- OSV: https://osv.dev/vulnerability/CVE-2026-27004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27004/
Summaries are generated and may contain mistakes; the official description above is the record.
