# CVE-2026-27009: OpenClaw affected by Stored XSS in Control UI via unsanitized assistant name/avatar in inline script injection

> Attackers can execute arbitrary JavaScript in the OpenClaw Control UI via unsanitized assistant names, potentially leading to session hijacking or data theft.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-37gc-85xm-2ww6

## What is CVE-2026-27009?

CVE-2026-27009 is a medium-severity cross-site scripting vulnerability in Openclaw Openclaw, published on 19 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

OpenClaw is a personal AI assistant. Prior to version 2026.2.15, a atored XSS issue in the OpenClaw Control UI when rendering assistant identity (name/avatar) into an inline `<script>` tag without script-context-safe escaping. A crafted value containing `</script>` could break out of the script tag and execute attacker-controlled JavaScript in the Control UI origin. Version 2026.2.15 removed inline script injection and serve bootstrap config from a JSON endpoint and added a restrictive Content Security Policy for the Control UI (`script-src 'self'`, no inline scripts).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27009?

2 open source packages ship an affected version, including openclaw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openclaw` | npm | All versions | 2026.2.15 |
| `openclaw` | npm | All versions | 2026.2.15 |

Products: Openclaw Openclaw.

## How do I fix CVE-2026-27009?

Upgrade openclaw to 2026.2.15 or later.

## Is CVE-2026-27009 being exploited?

There is no known exploitation of CVE-2026-27009 in the wild and no public exploit code.

## Other vulnerabilities in Openclaw Openclaw

- [CVE-2026-28363](https://insights.sbomify.com/CVE-2026-28363/): Security feature bypass in OpenClaw (critical 9.9)
- [CVE-2026-30741](https://insights.sbomify.com/CVE-2026-30741/): Code injection in n/a (critical 9.8)
- [CVE-2026-33579](https://insights.sbomify.com/CVE-2026-33579/): OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval (critical 9.4)
- [CVE-2026-32922](https://insights.sbomify.com/CVE-2026-32922/): OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate (critical 9.4)
- [CVE-2026-32978](https://insights.sbomify.com/CVE-2026-32978/): OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27009 and fix it if it is affected.

What it is: CVE-2026-27009 is a medium-severity cross-site scripting vulnerability in Openclaw Openclaw, published on 19 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27009 in the wild and no public exploit code.

Affected packages and fixed versions:
- openclaw (npm): affected all versions; fixed in 2026.2.15
- openclaw (npm): affected all versions; fixed in 2026.2.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27009/ (Markdown: https://insights.sbomify.com/CVE-2026-27009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27009
- OSV: https://osv.dev/vulnerability/CVE-2026-27009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27009/
Summaries are generated and may contain mistakes; the official description above is the record.
