CVE-2026-27016 LibreNMS has Stored XSS in Custom OID - unit parameter missing strip_tags()
Attackers can inject malicious scripts via the unit parameter in Custom OID settings, leading to session hijacking or code execution in LibreNMS.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-27016?
CVE-2026-27016 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 20 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 24.10.0 through 26.1.1 are vulnerable to Stored XSS via the unit parameter in Custom OID. The Custom OID functionality lacks strip_tags() sanitization while other fields (name, oid, datatype) are sanitized. The unsanitized value is stored in the database and rendered without HTML escaping. This issue is fixed in version 26.2.0.
Which versions are affected by CVE-2026-27016?
2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
librenms/librenms Packagist | From 24.10.0 | 26.2.0 |
librenms/librenms Packagist | From 24.10.0 | 26.2.0 |
Products include Librenms Librenms.
How do I fix CVE-2026-27016?
Upgrade librenms/librenms to 26.2.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-27016 being exploited?
There is no known exploitation of CVE-2026-27016 in the wild and no public exploit code.
Other vulnerabilities in Librenms Librenms
Sources
Also known as GHSA-fqx6-693c-f55g.