# CVE-2026-27016: LibreNMS has Stored XSS in Custom OID - unit parameter missing strip_tags()

> Attackers can inject malicious scripts via the unit parameter in Custom OID settings, leading to session hijacking or code execution in LibreNMS.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** GHSA-fqx6-693c-f55g

## What is CVE-2026-27016?

CVE-2026-27016 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 20 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 24.10.0 through 26.1.1 are vulnerable to Stored XSS via the unit parameter in Custom OID. The Custom OID functionality lacks strip_tags() sanitization while other fields (name, oid, datatype) are sanitized. The unsanitized value is stored in the database and rendered without HTML escaping. This issue is fixed in version 26.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-27016?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | From 24.10.0 | 26.2.0 |
| `librenms/librenms` | Packagist | From 24.10.0 | 26.2.0 |

Products: Librenms Librenms.

## How do I fix CVE-2026-27016?

Upgrade librenms/librenms to 26.2.0 or later.

## Is CVE-2026-27016 being exploited?

There is no known exploitation of CVE-2026-27016 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27016 and fix it if it is affected.

What it is: CVE-2026-27016 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 20 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27016 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected from 24.10.0; fixed in 26.2.0
- librenms/librenms (Packagist): affected from 24.10.0; fixed in 26.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27016/ (Markdown: https://insights.sbomify.com/CVE-2026-27016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27016
- OSV: https://osv.dev/vulnerability/CVE-2026-27016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27016/
Summaries are generated and may contain mistakes; the official description above is the record.
