CVE-2026-27017 uTLS has a Chrome Parrot Fingerprint Vulnerability due to GREASE ECH Cipher Suite Mismatch
uTLS library fails to mimic Chrome's GREASE ECH cipher suite selection, allowing fingerprinting detection of non-browser clients.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-27017?
CVE-2026-27017 is a low-severity vulnerability in refraction-networking utls, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
uTLS is a fork of crypto/tls, created to customize ClientHello for fingerprinting resistance while still using it for the handshake. Versions 1.6.0 through 1.8.0 contain a fingerprint mismatch with Chrome when using GREASE ECH, related to cipher suite selection. When Chrome selects the preferred cipher suite in the outer ClientHello and for ECH, it does so consistently based on hardware support—for example, if it prefers AES for the outer cipher suite, it also uses AES for ECH. However, the Chrome parrot in uTLS hardcodes AES preference for outer cipher suites but selects the ECH cipher suite randomly between AES and ChaCha20. This creates a 50% chance of selecting ChaCha20 for ECH while using AES for the outer cipher suite, a combination impossible in Chrome. This issue only affects GREASE ECH; in real ECH, Chrome selects the first valid cipher suite when AES is preferred, which uTLS handles correctly. This issue has been fixed in version 1.8.1.
Weakness: CWE-1240
Which versions are affected by CVE-2026-27017?
3 open source packages ship an affected version, including github.com/refraction-networking/utls. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/refraction-networking/utls Go | From 1.6.0 | 1.8.1 |
github.com/refraction-networking/utls Go | From 1.6.0 | 1.8.1 |
github.com/refraction-networking/utls Go | From 1.6.0 | 1.8.1 |
Products include Refraction-Networking Utls.
How do I fix CVE-2026-27017?
Upgrade github.com/refraction-networking/utls to 1.8.1 or later.
Is CVE-2026-27017 being exploited?
There is no known exploitation of CVE-2026-27017 in the wild and no public exploit code.
Other vulnerabilities in refraction-networking utls
Sources
Also known as GHSA-7m29-f4hw-g2vx, GO-2026-4509, UBUNTU-CVE-2026-27017.