# CVE-2026-27018: Gotenberg: Chromium deny-list bypass via case-insensitive URL scheme

> Attackers can bypass Chromium deny-lists using mixed-case URL schemes to access restricted resources in Gotenberg document conversion services.

- **Severity:** High 7.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2026
- **Updated:** 31 Mar 2026
- **Also known as:** GHSA-jjwv-57xh-xr6r, GO-2026-4905

## What is CVE-2026-27018?

CVE-2026-27018 is a high-severity server-side request forgery vulnerability in gotenberg, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gotenberg is an API for converting document formats. Prior to version 8.29.0, the fix introduced for CVE-2024-21527 can be bypassed using mixed-case or uppercase URL schemes. This issue has been patched in version 8.29.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-27018?

6 open source packages ship an affected version, including github.com/gotenberg/gotenberg/v7 and github.com/gotenberg/gotenberg/v8. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions | None |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions to 7.10.2 | None |
| `github.com/gotenberg/gotenberg/v7` | Go | All versions to 7.10.2 | None |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.29.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.29.0 |
| `github.com/gotenberg/gotenberg/v8` | Go | All versions | 8.29.0 |

Products: Thecodingmachine Gotenberg.

## How do I fix CVE-2026-27018?

Upgrade to a fixed version.

## Is CVE-2026-27018 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27018 exists.

## Other vulnerabilities in gotenberg

- [CVE-2026-40281](https://insights.sbomify.com/CVE-2026-40281/): Gotenberg vulnerable to argument injection via newlines in ExifTool metadata values (critical 10.0)
- [CVE-2026-42589](https://insights.sbomify.com/CVE-2026-42589/): Gotenberg: Unauthenticated RCE via ExifTool Metadata Key Injection (critical 9.8)
- [CVE-2020-13450](https://insights.sbomify.com/CVE-2020-13450/): Path traversal in n/a (critical 9.8)
- [CVE-2020-13451](https://insights.sbomify.com/CVE-2020-13451/): Code injection in n/a (critical 9.8)
- [CVE-2020-13452](https://insights.sbomify.com/CVE-2020-13452/): Privilege escalation in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27018 and fix it if it is affected.

What it is: CVE-2026-27018 is a high-severity server-side request forgery vulnerability in gotenberg, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27018 exists.

Affected packages and fixed versions:
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions; no fix listed
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions up to 7.10.2; no fix listed
- github.com/gotenberg/gotenberg/v7 (Go): affected all versions up to 7.10.2; no fix listed
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.29.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.29.0
- github.com/gotenberg/gotenberg/v8 (Go): affected all versions; fixed in 8.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27018/ (Markdown: https://insights.sbomify.com/CVE-2026-27018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27018
- OSV: https://osv.dev/vulnerability/CVE-2026-27018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27018/
Summaries are generated and may contain mistakes; the official description above is the record.
