CVE-2026-27021 Discourse: Poll voters endpoint lacked post visibility checks

Medium 6.9 Published Updated

Attackers can view voter details for polls in any post, including private ones, due to missing visibility checks in the Discourse poll plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27021?

CVE-2026-27021 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 26 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, the voters endpoint in the poll plugin lacked post visibility checks which allowed unauthorized access to voters details of polls in any post. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.

Weakness: CWE-862

Which versions are affected by CVE-2026-27021?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2025.12.2, 2026.1.1

Products include Discourse Discourse.

How do I fix CVE-2026-27021?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-27021 being exploited?

There is no known exploitation of CVE-2026-27021 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-27021, GHSA-f5m5-9hpw-7c2g.

Is CVE-2026-27021 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free