# CVE-2026-27022: RediSearch Query Injection in @langchain/langgraph-checkpoint-redis

> Attackers can manipulate RediSearch queries via unescaped filter inputs to bypass access controls in LangGraph Redis checkpoints.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-5mx2-w598-339m

## What is CVE-2026-27022?

CVE-2026-27022 is a medium-severity vulnerability in langchain-ai langgraphjs, published on 20 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@langchain/langgraph-checkpoint-redis is the Redis checkpoint and store implementation for LangGraph. A query injection vulnerability exists in the @langchain/langgraph-checkpoint-redis package's filter handling. The RedisSaver and ShallowRedisSaver classes construct RediSearch queries by directly interpolating user-provided filter keys and values without proper escaping. RediSearch has special syntax characters that can modify query behavior, and when user-controlled data contains these characters, the query logic can be manipulated to bypass intended access controls. This vulnerability is fixed in 1.0.2.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-27022?

2 open source packages ship an affected version, including @langchain/langgraph-checkpoint-redis.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@langchain/langgraph-checkpoint-redis` | npm | All versions | 1.0.2 |
| `@langchain/langgraph-checkpoint-redis` | npm | All versions | 1.0.2 |

## How do I fix CVE-2026-27022?

Upgrade @langchain/langgraph-checkpoint-redis to 1.0.2 or later.

## Is CVE-2026-27022 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27022 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27022 and fix it if it is affected.

What it is: CVE-2026-27022 is a medium-severity vulnerability in langchain-ai langgraphjs, published on 20 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27022 exists.

Affected packages and fixed versions:
- @langchain/langgraph-checkpoint-redis (npm): affected all versions; fixed in 1.0.2
- @langchain/langgraph-checkpoint-redis (npm): affected all versions; fixed in 1.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27022/ (Markdown: https://insights.sbomify.com/CVE-2026-27022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27022
- OSV: https://osv.dev/vulnerability/CVE-2026-27022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27022/
Summaries are generated and may contain mistakes; the official description above is the record.
