# CVE-2026-2704: Open Babel CIF File transform3d.cpp DescribeAsString out-of-bounds

> An out-of-bounds read in Open Babel's CIF handler allows remote attackers to cause denial of service or disclose information.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 28 May 2026
- **Also known as:** DEBIAN-CVE-2026-2704, GHSA-6xw4-2g22-26h8, PYSEC-2026-2774, UBUNTU-CVE-2026-2704

## What is CVE-2026-2704?

CVE-2026-2704 is a medium-severity memory corruption vulnerability in Open Babel, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A security vulnerability has been detected in Open Babel up to 3.1.1. The affected element is the function OpenBabel::transform3d::DescribeAsString of the file src/math/transform3d.cpp of the component CIF File Handler. The manipulation leads to out-of-bounds read. It is possible to initiate the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 3.2.0 is sufficient to fix this issue. The identifier of the patch is e23a224b8fd9d7c2a7cde9ef4ec6afb4c05aa08a. It is suggested to install a patch to address this issue.

Weakness: CWE-125 (Out-of-bounds Read), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-2704?

3 open source packages ship an affected version, including openbabel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |

Products: Openbabel Open Babel.

## How do I fix CVE-2026-2704?

Upgrade openbabel to 3.2.0 or later.

## Is CVE-2026-2704 being exploited?

There is no known exploitation of CVE-2026-2704 in the wild and no public exploit code.

## Other vulnerabilities in Open Babel

- [CVE-2022-41793](https://insights.sbomify.com/CVE-2022-41793/): Open Babel has out-of-bounds write in CSR PadString (title field) (critical 9.8)
- [CVE-2022-42885](https://insights.sbomify.com/CVE-2022-42885/): Open Babel has uninitialized pointer dereference in GRO residue parser (critical 9.8)
- [CVE-2022-43467](https://insights.sbomify.com/CVE-2022-43467/): Open Babel has out-of-bounds write in PQS coord_file parser (critical 9.8)
- [CVE-2022-44451](https://insights.sbomify.com/CVE-2022-44451/): Open Babel has uninitialized pointer dereference in MSI atom parser (critical 9.8)
- [CVE-2022-46280](https://insights.sbomify.com/CVE-2022-46280/): Open Babel has uninitialized pointer dereference in PQS pFormat (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2704 and fix it if it is affected.

What it is: CVE-2026-2704 is a medium-severity memory corruption vulnerability in Open Babel, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-2704 in the wild and no public exploit code.

Affected packages and fixed versions:
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2704/ (Markdown: https://insights.sbomify.com/CVE-2026-2704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2704
- OSV: https://osv.dev/vulnerability/CVE-2026-2704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2704/
Summaries are generated and may contain mistakes; the official description above is the record.
