# CVE-2026-2705: Open Babel MOL2 File atom.h SetFormalCharge out-of-bounds

> Open Babel library contains an out-of-bounds read vulnerability in MOL2 file handling, potentially allowing remote attackers to cause denial of service or execute code.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 3 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-2705, GHSA-4w5w-4fhm-q483, PYSEC-2026-2770, UBUNTU-CVE-2026-2705

## What is CVE-2026-2705?

CVE-2026-2705 is a medium-severity memory corruption vulnerability in Open Babel, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was detected in Open Babel up to 3.1.1. The impacted element is the function OBAtom::SetFormalCharge in the library include/openbabel/atom.h of the component MOL2 File Handler. The manipulation results in out-of-bounds read. It is possible to launch the attack remotely. The exploit is now public and may be used. The patch is identified as e23a224b8fd9d7c2a7cde9ef4ec6afb4c05aa08a. A patch should be applied to remediate this issue. The project was informed of the problem early through an issue report but has not responded yet.

Weakness: CWE-125 (Out-of-bounds Read), CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-2705?

3 open source packages ship an affected version, including openbabel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |

Products: Openbabel Open Babel.

## How do I fix CVE-2026-2705?

Upgrade openbabel to 3.2.0 or later.

## Is CVE-2026-2705 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2705 exists.

## Other vulnerabilities in Open Babel

- [CVE-2022-41793](https://insights.sbomify.com/CVE-2022-41793/): Open Babel has out-of-bounds write in CSR PadString (title field) (critical 9.8)
- [CVE-2022-42885](https://insights.sbomify.com/CVE-2022-42885/): Open Babel has uninitialized pointer dereference in GRO residue parser (critical 9.8)
- [CVE-2022-43467](https://insights.sbomify.com/CVE-2022-43467/): Open Babel has out-of-bounds write in PQS coord_file parser (critical 9.8)
- [CVE-2022-44451](https://insights.sbomify.com/CVE-2022-44451/): Open Babel has uninitialized pointer dereference in MSI atom parser (critical 9.8)
- [CVE-2022-46280](https://insights.sbomify.com/CVE-2022-46280/): Open Babel has uninitialized pointer dereference in PQS pFormat (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2705 and fix it if it is affected.

What it is: CVE-2026-2705 is a medium-severity memory corruption vulnerability in Open Babel, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2705 exists.

Affected packages and fixed versions:
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2705/ (Markdown: https://insights.sbomify.com/CVE-2026-2705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2705
- OSV: https://osv.dev/vulnerability/CVE-2026-2705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2705/
Summaries are generated and may contain mistakes; the official description above is the record.
