# CVE-2026-27099: Jenkins has a stored XSS vulnerability in node offline cause description

> Attackers with specific permissions can inject malicious scripts into Jenkins agent offline causes, leading to stored XSS and potential session hijacking.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Feb 2026
- **Updated:** 18 Feb 2026
- **Also known as:** BIT-jenkins-2026-27099, GHSA-85h6-5m3v-gx37, MINI-32fx-4rqj-fg3x, MINI-6x9m-wmr9-vpc3, MINI-9vvp-vqwm-cj8j, MINI-p94v-6qx3-mq7x, MINI-qv89-j92h-3r3h, MINI-xp22-25fc-94g6, ROOT-APP-MAVEN-CVE-2026-27099

## What is CVE-2026-27099?

CVE-2026-27099 is a high-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 18 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins 2.483 through 2.550 (both inclusive), LTS 2.492.1 through 2.541.1 (both inclusive) does not escape the user-provided description of the "Mark temporarily offline" offline cause, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure or Agent/Disconnect permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27099?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.483 | 2.541.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.483 | 2.541.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.542 | 2.551 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.542 | 2.551 |
| `jenkins` | Bitnami | From 2.483.0 | 2.541.2, 2.551.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-27099?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.541.2 or 2.551.

## Is CVE-2026-27099 being exploited?

There is no known exploitation of CVE-2026-27099 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27099 and fix it if it is affected.

What it is: CVE-2026-27099 is a high-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 18 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27099 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.483; fixed in 2.541.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.483; fixed in 2.541.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.542; fixed in 2.551
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.542; fixed in 2.551
- jenkins (Bitnami): affected from 2.483.0; fixed in 2.541.2, 2.551.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27099/ (Markdown: https://insights.sbomify.com/CVE-2026-27099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27099
- OSV: https://osv.dev/vulnerability/CVE-2026-27099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27099/
Summaries are generated and may contain mistakes; the official description above is the record.
