# CVE-2026-27100: Jenkins has a build information disclosure vulnerability through Run Parameter

> Attackers with specific permissions can leak job and build existence details via Run Parameters, exposing sensitive metadata.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2026
- **Updated:** 18 Feb 2026
- **Also known as:** BIT-jenkins-2026-27100, GHSA-wfhp-qgm8-5p5c, MINI-4xf3-9g5f-7gf6, MINI-6852-fgrf-4hwg, MINI-9vpw-gcgh-m77h, MINI-rcv9-rg56-6chh, MINI-vc6v-4fm7-rgrj, MINI-whr7-45w6-3wxf, ROOT-APP-MAVEN-CVE-2026-27100

## What is CVE-2026-27100?

CVE-2026-27100 is a medium-severity vulnerability in Jenkins Jenkins, published on 18 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins 2.550 and earlier, LTS 2.541.1 and earlier accepts Run Parameter values that refer to builds the user submitting the build does not have access to, allowing attackers with Item/Build and Item/Configure permission to obtain information about the existence of jobs, the existence of builds, and if a specified build exists, its display name.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-27100?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.541.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.541.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.542 | 2.551 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.542 | 2.551 |
| `jenkins` | Bitnami | From 2.483.0 | 2.541.2, 2.551.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2026-27100?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.541.2 or 2.551.

## Is CVE-2026-27100 being exploited?

There is no known exploitation of CVE-2026-27100 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27100 and fix it if it is affected.

What it is: CVE-2026-27100 is a medium-severity vulnerability in Jenkins Jenkins, published on 18 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27100 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.541.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.541.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.542; fixed in 2.551
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.542; fixed in 2.551
- jenkins (Bitnami): affected from 2.483.0; fixed in 2.541.2, 2.551.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27100/ (Markdown: https://insights.sbomify.com/CVE-2026-27100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27100
- OSV: https://osv.dev/vulnerability/CVE-2026-27100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27100/
Summaries are generated and may contain mistakes; the official description above is the record.
