CVE-2026-27112 Kargo has an Authorization Bypass Vulnerability in Batch Resource Creation API Endpoints
Attackers can bypass authorization in Kargo's batch API to inject resources, escalate privileges, and achieve remote code execution or secret exfiltration.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27112?
CVE-2026-27112 is a critical authentication bypass vulnerability in akuity kargo, published on 20 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kargo manages and automates the promotion of software artifacts. From 1.7.0 to before v1.7.8, v1.8.11, and v1.9.3, the batch resource creation endpoints of both Kargo's legacy gRPC API and newer REST API accept multi-document YAML payloads. Specially crafted payloads can manifest a bug present in the logic of both endpoints to inject arbitrary resources (of specific types only) into the underlying namespace of an existing Project using the API server's own permissions when that behavior was not intended. Critically, an attacker may exploit this as a vector for elevating their own permissions, which can then be leveraged to achieve remote code execution or secret exfiltration. Exfiltrated artifact repository credentials can be leveraged, in turn, to execute further attacks. In some configurations of the Kargo control plane's underlying Kubernetes cluster, elevated permissions may additionally be leveraged to achieve remote code execution or secret exfiltration using kubectl. This can reduce the complexity of the attack, however, worst case scenarios remain entirely achievable even without this. This vulnerability is fixed in v1.7.8, v1.8.11, and v1.9.3.
Weakness: CWE-863
Which versions are affected by CVE-2026-27112?
7 open source packages ship an affected version, including github.com/akuity/kargo. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/akuity/kargo Go | From 1.7.0 | 1.7.8, 1.8.11, 1.9.3 |
github.com/akuity/kargo Go | From 1.7.0 | 1.7.8 |
github.com/akuity/kargo Go | From 1.7.0 | 1.7.8 |
github.com/akuity/kargo Go | From 1.8.0-rc.1 | 1.8.11 |
github.com/akuity/kargo Go | From 1.8.0-rc.1 | 1.8.11 |
github.com/akuity/kargo Go | From 1.9.0-rc.1 | 1.9.3 |
1 more packages
github.com/akuity/kargo Go | From 1.9.0-rc.1 | 1.9.3 |
Products include Akuity Kargo.
How do I fix CVE-2026-27112?
Upgrade github.com/akuity/kargo to a fixed version for your release line: 1.7.8, 1.8.11 or 1.9.3.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-27112 being exploited?
There is no known exploitation of CVE-2026-27112 in the wild and no public exploit code.
Other vulnerabilities in akuity kargo
- CVE-2026-24748 Kargo's `GetConfig()` and `RefreshResource()` API endpoints allow unauthenticated access
- CVE-2026-27111 Kargo has Missing Authorization Vulnerabilities in Approval & Promotion REST API Endpoints
- CVE-2026-32828 Kargo: SSRF in Promotion http/http-download Steps Enables Internal Network Access and Data Exfiltration
Sources
Also known as GHSA-7g9x-cp9g-92mr, GO-2026-4516.