# CVE-2026-27112: Kargo has an Authorization Bypass Vulnerability in Batch Resource Creation API Endpoints

> Attackers can bypass authorization in Kargo's batch API to inject resources, escalate privileges, and achieve remote code execution or secret exfiltration.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-7g9x-cp9g-92mr, GO-2026-4516

## What is CVE-2026-27112?

CVE-2026-27112 is a critical authentication bypass vulnerability in akuity kargo, published on 20 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kargo manages and automates the promotion of software artifacts. From 1.7.0 to before v1.7.8, v1.8.11, and v1.9.3, the batch resource creation endpoints of both Kargo's legacy gRPC API and newer REST API accept multi-document YAML payloads. Specially crafted payloads can manifest a bug present in the logic of both endpoints to inject arbitrary resources (of specific types only) into the underlying namespace of an existing Project using the API server's own permissions when that behavior was not intended. Critically, an attacker may exploit this as a vector for elevating their own permissions, which can then be leveraged to achieve remote code execution or secret exfiltration. Exfiltrated artifact repository credentials can be leveraged, in turn, to execute further attacks. In some configurations of the Kargo control plane's underlying Kubernetes cluster, elevated permissions may additionally be leveraged to achieve remote code execution or secret exfiltration using kubectl. This can reduce the complexity of the attack, however, worst case scenarios remain entirely achievable even without this. This vulnerability is fixed in v1.7.8, v1.8.11, and v1.9.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-27112?

7 open source packages ship an affected version, including github.com/akuity/kargo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/akuity/kargo` | Go | From 1.7.0 | 1.7.8, 1.8.11, 1.9.3 |
| `github.com/akuity/kargo` | Go | From 1.7.0 | 1.7.8 |
| `github.com/akuity/kargo` | Go | From 1.7.0 | 1.7.8 |
| `github.com/akuity/kargo` | Go | From 1.8.0-rc.1 | 1.8.11 |
| `github.com/akuity/kargo` | Go | From 1.8.0-rc.1 | 1.8.11 |
| `github.com/akuity/kargo` | Go | From 1.9.0-rc.1 | 1.9.3 |
| `github.com/akuity/kargo` | Go | From 1.9.0-rc.1 | 1.9.3 |

Products: Akuity Kargo.

## How do I fix CVE-2026-27112?

Upgrade github.com/akuity/kargo to a fixed version for your release line: 1.7.8, 1.8.11 or 1.9.3.

## Is CVE-2026-27112 being exploited?

There is no known exploitation of CVE-2026-27112 in the wild and no public exploit code.

## Other vulnerabilities in akuity kargo

- [CVE-2026-24748](https://insights.sbomify.com/CVE-2026-24748/): Kargo's `GetConfig()` and `RefreshResource()` API endpoints allow unauthenticated access (medium 6.9)
- [CVE-2026-27111](https://insights.sbomify.com/CVE-2026-27111/): Kargo has Missing Authorization Vulnerabilities in Approval & Promotion REST API Endpoints (medium 5.3)
- [CVE-2026-32828](https://insights.sbomify.com/CVE-2026-32828/): Kargo: SSRF in Promotion http/http-download Steps Enables Internal Network Access and Data Exfiltration (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27112 and fix it if it is affected.

What it is: CVE-2026-27112 is a critical authentication bypass vulnerability in akuity kargo, published on 20 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27112 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/akuity/kargo (Go): affected from 1.7.0; fixed in 1.7.8, 1.8.11, 1.9.3
- github.com/akuity/kargo (Go): affected from 1.7.0; fixed in 1.7.8
- github.com/akuity/kargo (Go): affected from 1.7.0; fixed in 1.7.8
- github.com/akuity/kargo (Go): affected from 1.8.0-rc.1; fixed in 1.8.11
- github.com/akuity/kargo (Go): affected from 1.8.0-rc.1; fixed in 1.8.11
- github.com/akuity/kargo (Go): affected from 1.9.0-rc.1; fixed in 1.9.3
- github.com/akuity/kargo (Go): affected from 1.9.0-rc.1; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27112/ (Markdown: https://insights.sbomify.com/CVE-2026-27112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27112
- OSV: https://osv.dev/vulnerability/CVE-2026-27112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27112/
Summaries are generated and may contain mistakes; the official description above is the record.
