# CVE-2026-27118: Cache poisoning in @sveltejs/adapter-vercel


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-9pq4-5hcf-288c

## What is CVE-2026-27118?

CVE-2026-27118 is a medium-severity vulnerability in sveltejs kit, published on 20 Feb 2026. 

### Official description

SvelteKit is a framework for rapidly developing robust, performant web applications using Svelte. Versions of @sveltejs/adapter-vercel prior to 6.3.2 are vulnerable to cache poisoning. An internal query parameter intended for Incremental Static Regeneration (ISR) is accessible on all routes, allowing an attacker to cause sensitive user-specific responses to be cached and served to other users. Successful exploitation requires a victim to visit an attacker-controlled link while authenticated. Existing deployments are protected by Vercel's WAF, but users should upgrade as soon as possible. This vulnerability is fixed in 6.3.2.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-27118?

2 open source packages ship an affected version, including @sveltejs/adapter-vercel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sveltejs/adapter-vercel` | npm | All versions | 6.3.2 |
| `@sveltejs/adapter-vercel` | npm | All versions | 6.3.2 |

## How do I fix CVE-2026-27118?

Upgrade @sveltejs/adapter-vercel to 6.3.2 or later.

## Is CVE-2026-27118 being exploited?

There is no known exploitation of CVE-2026-27118 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27118 and fix it if it is affected.

What it is: CVE-2026-27118 is a medium-severity vulnerability in sveltejs kit, published on 20 Feb 2026. 
Exploitation: There is no known exploitation of CVE-2026-27118 in the wild and no public exploit code.

Affected packages and fixed versions:
- @sveltejs/adapter-vercel (npm): affected all versions; fixed in 6.3.2
- @sveltejs/adapter-vercel (npm): affected all versions; fixed in 6.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27118/ (Markdown: https://insights.sbomify.com/CVE-2026-27118/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27118
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27118
- OSV: https://osv.dev/vulnerability/CVE-2026-27118

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27118/
Summaries are generated and may contain mistakes; the official description above is the record.
