CVE-2026-27119 Svelte affected by XSS in SSR `<option>` element

Medium 5.1 Published Updated

Attackers can inject HTML via unescaped SSR option elements, potentially leading to code execution in server-rendered applications.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27119?

CVE-2026-27119 is a medium-severity cross-site scripting vulnerability in sveltejs svelte, published on 20 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

svelte performance oriented web framework. From 5.39.3, <=5.51.4, in certain circumstances, the server-side rendering output of an <option> element does not properly escape its content, potentially allowing HTML injection in the SSR output. Client-side rendering is not affected. This vulnerability is fixed in 5.51.5.

Weakness: CWE-79

Which versions are affected by CVE-2026-27119?

2 open source packages ship an affected version, including svelte. It affects 1 product.

PackageAffectedFixed in
svelte npmFrom 5.39.35.51.5
svelte npmFrom 5.39.35.51.5

Products include Svelte Svelte.

How do I fix CVE-2026-27119?

Upgrade svelte to 5.51.5 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-27119 being exploited?

There is no known exploitation of CVE-2026-27119 in the wild and no public exploit code.

Sources

Also known as GHSA-h7h7-mm68-gmrc.

Is CVE-2026-27119 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free