{"answers":{"affected":"3 open source packages ship an affected version, including fastmcp. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27124 exists.","fix":"Upgrade fastmcp to 3.2.0 or later.","what":"CVE-2026-27124 is a high-severity authentication bypass vulnerability in jlowin fastmcp, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27124 and fix it if it is affected.\n\nWhat it is: CVE-2026-27124 is a high-severity authentication bypass vulnerability in jlowin fastmcp, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27124 exists.\n\nAffected packages and fixed versions:\n- fastmcp (PyPI): affected all versions; fixed in 3.2.0\n- fastmcp (PyPI): affected all versions; fixed in 3.2.0\n- fastmcp (PyPI): affected all versions; fixed in 3.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27124/ (Markdown: https://insights.sbomify.com/CVE-2026-27124/index.md)","id":"CVE-2026-27124","markdown":"https://insights.sbomify.com/CVE-2026-27124/index.md","name":"CVE-2026-27124","record":{"aliases":["ECHO-86a3-9d3c-b622","GHSA-rww4-4w9c-7733","PYSEC-2026-2476","ROOT-APP-PYPI-CVE-2026-27124"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"FastMCP framework","requires_auth":"none","summary":"Attackers can bypass OAuth consent checks in FastMCP, leading to confused deputy attacks and unauthorized account access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fastmcp","vendor":"jlowin"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-441","name":"Unintended Proxy or Intermediary"}],"description":"FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, while testing the GitHubProvider OAuth integration, which allows authentication to a FastMCP MCP server via a FastMCP OAuthProxy using GitHub OAuth, it was discovered that the FastMCP OAuthProxy does not properly validate the user's consent upon receiving the authorization code from GitHub. In combination with GitHub’s behavior of skipping the consent page for previously authorized clients, this introduces a Confused Deputy vulnerability. This issue has been patched in version 3.2.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities","id":"CVE-2026-27124","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Svelte SSR attribute spreading includes inherited properties from prototype chain","id":"CVE-2026-27125"},"packages":[{"ecosystem":"PyPI","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":null,"source":"GHSA-rww4-4w9c-7733"},{"ecosystem":"PyPI","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":"pkg:pypi/fastmcp","source":"GHSA-rww4-4w9c-7733"},{"ecosystem":"PyPI","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"fastmcp","purl":"pkg:pypi/fastmcp","source":"PYSEC-2026-2476"}],"prev":{"headline":"Reason: This candidate was issued in error.","id":"CVE-2026-27123"},"products":["fastmcp"],"published":"2026-04-03","related":[{"cvss_score":10,"headline":"FastMCP OpenAPI Provider has an SSRF \u0026 Path Traversal Vulnerability","id":"CVE-2026-32871","kev_date_added":null,"published":"2026-04-02"},{"cvss_score":7.4,"headline":"FastMCP OAuth Proxy token reuse across MCP servers","id":"CVE-2025-69196","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":6.7,"headline":"FastMCP has a Command Injection vulnerability - Gemini CLI","id":"CVE-2025-64340","kev_date_added":null,"published":"2026-04-03"},{"cvss_score":5.4,"headline":"FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name","id":"CVE-2025-62801","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":5.3,"headline":"FastMCP vulnerable to reflected XSS in client's callback page","id":"CVE-2025-62800","kev_date_added":null,"published":"2025-10-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-03","vendors":["jlowin"]},"summary":"Attackers can bypass OAuth consent checks in FastMCP, leading to confused deputy attacks and unauthorized account access.","url":"https://insights.sbomify.com/CVE-2026-27124/"}