# CVE-2026-27124: FastMCP: Missing Consent Verification in OAuth Proxy Callback Facilitates Confused Deputy Vulnerabilities

> Attackers can bypass OAuth consent checks in FastMCP, leading to confused deputy attacks and unauthorized account access.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2026
- **Updated:** 3 Apr 2026
- **Also known as:** ECHO-86a3-9d3c-b622, GHSA-rww4-4w9c-7733, PYSEC-2026-2476, ROOT-APP-PYPI-CVE-2026-27124

## What is CVE-2026-27124?

CVE-2026-27124 is a high-severity authentication bypass vulnerability in jlowin fastmcp, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FastMCP is the standard framework for building MCP applications. Prior to version 3.2.0, while testing the GitHubProvider OAuth integration, which allows authentication to a FastMCP MCP server via a FastMCP OAuthProxy using GitHub OAuth, it was discovered that the FastMCP OAuthProxy does not properly validate the user's consent upon receiving the authorization code from GitHub. In combination with GitHub’s behavior of skipping the consent page for previously authorized clients, this introduces a Confused Deputy vulnerability. This issue has been patched in version 3.2.0.

Weakness: CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-27124?

3 open source packages ship an affected version, including fastmcp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastmcp` | PyPI | All versions | 3.2.0 |
| `fastmcp` | PyPI | All versions | 3.2.0 |
| `fastmcp` | PyPI | All versions | 3.2.0 |

Products: Jlowin Fastmcp.

## How do I fix CVE-2026-27124?

Upgrade fastmcp to 3.2.0 or later.

## Is CVE-2026-27124 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27124 exists.

## Other vulnerabilities in jlowin fastmcp

- [CVE-2026-32871](https://insights.sbomify.com/CVE-2026-32871/): FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability (critical 10.0)
- [CVE-2025-69196](https://insights.sbomify.com/CVE-2025-69196/): FastMCP OAuth Proxy token reuse across MCP servers (high 7.4)
- [CVE-2025-64340](https://insights.sbomify.com/CVE-2025-64340/): FastMCP has a Command Injection vulnerability - Gemini CLI (medium 6.7)
- [CVE-2025-62801](https://insights.sbomify.com/CVE-2025-62801/): FastMCP vulnerable to windows command injection in FastMCP Cursor installer via server_name (medium 5.4)
- [CVE-2025-62800](https://insights.sbomify.com/CVE-2025-62800/): FastMCP vulnerable to reflected XSS in client's callback page (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27124 and fix it if it is affected.

What it is: CVE-2026-27124 is a high-severity authentication bypass vulnerability in jlowin fastmcp, published on 3 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27124 exists.

Affected packages and fixed versions:
- fastmcp (PyPI): affected all versions; fixed in 3.2.0
- fastmcp (PyPI): affected all versions; fixed in 3.2.0
- fastmcp (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27124/ (Markdown: https://insights.sbomify.com/CVE-2026-27124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27124
- OSV: https://osv.dev/vulnerability/CVE-2026-27124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27124/
Summaries are generated and may contain mistakes; the official description above is the record.
