# CVE-2026-27126: Craft CMS has Stored XSS in Table Field via "HTML" Column Type

> Stored XSS in Craft CMS Table Field allows admin attackers to execute JavaScript when other users view malicious content.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-3jh3-prx3-w6wc

## What is CVE-2026-27126?

CVE-2026-27126 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 24 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Craft is a content management system (CMS). In versions 4.5.0-RC1 through 4.16.18 and 5.0.0-RC1 through 5.8.22, a stored Cross-site Scripting (XSS) vulnerability exists in the `editableTable.twig` component when using the `html` column type. The application fails to sanitize the input, allowing an attacker to execute arbitrary JavaScript when another user views a page with the malicious table field. In order to exploit the vulnerability, an attacker must have an administrator account, and `allowAdminChanges` must be enabled in production, which is against Craft's security recommendations. Versions 4.16.19 and 5.8.23 patch the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27126?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.5.0-RC1 | 4.16.19 |
| `craftcms/cms` | Packagist | From 4.5.0-RC1 | 4.16.19 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.23 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.23 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-27126?

Upgrade craftcms/cms to a fixed version for your release line: 4.16.19 or 5.8.23.

## Is CVE-2026-27126 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27126 exists.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27126 and fix it if it is affected.

What it is: CVE-2026-27126 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 24 Feb 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27126 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.5.0-RC1; fixed in 4.16.19
- craftcms/cms (Packagist): affected from 4.5.0-RC1; fixed in 4.16.19
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.23
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27126/ (Markdown: https://insights.sbomify.com/CVE-2026-27126/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27126
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27126
- OSV: https://osv.dev/vulnerability/CVE-2026-27126

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27126/
Summaries are generated and may contain mistakes; the official description above is the record.
