# CVE-2026-27128: Craft CMS's race condition in Token Service potentially allows for token usage greater than the token limit

> Attackers can exploit a race condition in Craft CMS token validation to reuse limited-use impersonation tokens, potentially escalating privileges.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 28 Feb 2026
- **Also known as:** GHSA-6fx5-5cw5-4897

## What is CVE-2026-27128?

CVE-2026-27128 is a medium-severity vulnerability in Craftcms Craft Cms, published on 24 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Craft is a content management system (CMS). In versions 4.5.0-RC1 through 4.16.18 and 5.0.0-RC1 through 5.8.22, a Time-of-Check-Time-of-Use (TOCTOU) race condition exists in Craft CMS’s token validation service for tokens that explicitly set a limited usage. The `getTokenRoute()` method reads a token’s usage count, checks if it’s within limits, then updates the database in separate non-atomic operations. By sending concurrent requests, an attacker can use a single-use impersonation token multiple times before the database update completes. To make this work, an attacker needs to obtain a valid user account impersonation URL with a non-expired token via some other means and exploit a race condition while bypassing any rate-limiting rules in place. For this to be a privilege escalation, the impersonation URL must include a token for a user account with more permissions than the current user. Versions 4.16.19 and 5.8.23 patch the issue.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-27128?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.5.0-RC1 | 4.16.19 |
| `craftcms/cms` | Packagist | From 4.5.0-RC1 | 4.16.19 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.23 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.23 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-27128?

Upgrade craftcms/cms to a fixed version for your release line: 4.16.19 or 5.8.23.

## Is CVE-2026-27128 being exploited?

There is no known exploitation of CVE-2026-27128 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27128 and fix it if it is affected.

What it is: CVE-2026-27128 is a medium-severity vulnerability in Craftcms Craft Cms, published on 24 Feb 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27128 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.5.0-RC1; fixed in 4.16.19
- craftcms/cms (Packagist): affected from 4.5.0-RC1; fixed in 4.16.19
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.23
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27128/ (Markdown: https://insights.sbomify.com/CVE-2026-27128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27128
- OSV: https://osv.dev/vulnerability/CVE-2026-27128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27128/
Summaries are generated and may contain mistakes; the official description above is the record.
