# CVE-2026-27129: Cloud Metadata SSRF Protection Bypass via IPv6 Resolution

> Authenticated users with specific GraphQL permissions can bypass SSRF protections via IPv6 resolution to access cloud metadata.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 28 Feb 2026
- **Also known as:** GHSA-v2gc-rm6g-wrw9

## What is CVE-2026-27129?

CVE-2026-27129 is a medium-severity server-side request forgery vulnerability in Craftcms Craft Cms, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft is a content management system (CMS). In versions 4.5.0-RC1 through 4.16.18 and 5.0.0-RC1 through 5.8.22, the SSRF validation in Craft CMS’s GraphQL Asset mutation uses `gethostbyname()`, which only resolves IPv4 addresses. When a hostname has only AAAA (IPv6) records, the function returns the hostname string itself, causing the blocklist comparison to always fail and completely bypassing SSRF protection. This is a bypass of the security fix for CVE-2025-68437. Exploitation requires GraphQL schema permissions for editing assets in the `<VolumeName>` volume and creating assets in the `<VolumeName>` volume. These permissions may be granted to authenticated users with appropriate GraphQL schema access and/or Public Schema (if misconfigured with write permissions). Versions 4.16.19 and 5.8.23 patch the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-27129?

4 open source packages ship an affected version, including craftcms/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 3.5.0 | 4.16.19 |
| `craftcms/cms` | Packagist | From 3.5.0 | 4.16.19 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.23 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.8.23 |

Products: Craftcms Craft Cms.

## How do I fix CVE-2026-27129?

Upgrade craftcms/cms to a fixed version for your release line: 4.16.19 or 5.8.23.

## Is CVE-2026-27129 being exploited?

There is no known exploitation of CVE-2026-27129 in the wild and no public exploit code.

## Other vulnerabilities in Craftcms Craft Cms

- [CVE-2025-32432](https://insights.sbomify.com/CVE-2025-32432/): Craft CMS Code Injection (critical 10.0, exploited in the wild)
- [CVE-2024-56145](https://insights.sbomify.com/CVE-2024-56145/): Craft CMS Code Injection (critical 9.3, exploited in the wild)
- [CVE-2025-23209](https://insights.sbomify.com/CVE-2025-23209/): Craft CMS Code Injection (high 8.1, exploited in the wild)
- [CVE-2025-35939](https://insights.sbomify.com/CVE-2025-35939/): Craft CMS External Control of Assumed-Immutable Web Parameter (medium 6.9, exploited in the wild)
- [CVE-2023-41892](https://insights.sbomify.com/CVE-2023-41892/): Craft CMS Remote Code Execution vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27129 and fix it if it is affected.

What it is: CVE-2026-27129 is a medium-severity server-side request forgery vulnerability in Craftcms Craft Cms, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27129 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 3.5.0; fixed in 4.16.19
- craftcms/cms (Packagist): affected from 3.5.0; fixed in 4.16.19
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.23
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.8.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27129/ (Markdown: https://insights.sbomify.com/CVE-2026-27129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27129
- OSV: https://osv.dev/vulnerability/CVE-2026-27129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27129/
Summaries are generated and may contain mistakes; the official description above is the record.
