# CVE-2026-27134: Strimzi: All CAs from a custom CA chain consisting of multiple CAs are trusted for mTLS user autentication

> Strimzi incorrectly trusts all CAs in a multi-stage custom CA chain, allowing unauthorized users with certificates from any chain CA to authenticate via mTLS.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Feb 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-2qwx-rq6j-8r6j

## What is CVE-2026-27134?

CVE-2026-27134 is a high-severity authentication bypass vulnerability in strimzi-kafka-operator, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strimzi provides a way to run an Apache Kafka cluster on Kubernetes or OpenShift in various deployment configurations. In versions  0.49.0 through 0.50.0, when using a custom Cluster or Clients CA with a multistage CA chain consisting of multiple CAs, Strimzi incorrectly configures the trusted certificates for mTLS authentication on the internal as well as user-configured listeners. All CAs from the CA chain will be trusted. And users with certificates signed by any of the CAs in the chain will be able to authenticate. This issue affects only users using a custom Cluster or Clients CA with a multistage CA chain consisting of multiple CAs. It does not affect users using the Strimzi-managed Cluster and Clients CAs. It also does not affect users using custom Cluster or Clients CA with only a single CA (i.e., no CA chain with multiple CAs). This issue has been fixed in version 0.50.1. To workaround this issue, instead of providing the full CA chain as the custom CA, users can provide only the single CA that should be used.

Weakness: CWE-296 (Improper Following of a Certificate's Chain of Trust), CWE-295 (Improper Certificate Validation), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-27134?

It affects 1 product.


Products: Linuxfoundation Strimzi Kafka Operator.

## How do I fix CVE-2026-27134?

No fix has been published for CVE-2026-27134 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-27134 being exploited?

There is no known exploitation of CVE-2026-27134 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27134 and fix it if it is affected.

What it is: CVE-2026-27134 is a high-severity authentication bypass vulnerability in strimzi-kafka-operator, published on 20 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27134 in the wild and no public exploit code.

Affected product: strimzi-kafka-operator. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27134/ (Markdown: https://insights.sbomify.com/CVE-2026-27134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27134
- OSV: https://osv.dev/vulnerability/CVE-2026-27134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27134/
Summaries are generated and may contain mistakes; the official description above is the record.
