CVE-2026-27154 Discourse has XSS when editing a malicious post

Low 1.3 Published Updated

Attackers can execute arbitrary scripts via malicious user names in Discourse when specific display settings are enabled, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27154?

CVE-2026-27154 is a low-severity cross-site scripting vulnerability in Discourse Discourse, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, a user full name can be evaluated as raw HTML when the following settings are set: `display_name_on_posts` => true; and `prioritize_username_in_ux` => false. Editing a post of a malicious user would trigger an XSS. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.

Weakness: CWE-79

Which versions are affected by CVE-2026-27154?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2025.12.2, 2026.1.1

Products include Discourse Discourse.

How do I fix CVE-2026-27154?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-27154 being exploited?

There is no known exploitation of CVE-2026-27154 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-27154, GHSA-xv43-5gcp-wgw8.

Is CVE-2026-27154 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free