# CVE-2026-27154: Discourse has XSS when editing a malicious post

> Attackers can execute arbitrary scripts via malicious user names in Discourse when specific display settings are enabled, potentially compromising user accounts.

- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 2 Mar 2026
- **Also known as:** BIT-discourse-2026-27154, GHSA-xv43-5gcp-wgw8

## What is CVE-2026-27154?

CVE-2026-27154 is a low-severity cross-site scripting vulnerability in Discourse Discourse, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, a user full name can be evaluated as raw HTML when the following settings are set: `display_name_on_posts` => true; and `prioritize_username_in_ux` => false. Editing a post of a malicious user would trigger an XSS. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-27154?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2025.12.2, 2026.1.1 |

Products: Discourse Discourse.

## How do I fix CVE-2026-27154?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

## Is CVE-2026-27154 being exploited?

There is no known exploitation of CVE-2026-27154 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27154 and fix it if it is affected.

What it is: CVE-2026-27154 is a low-severity cross-site scripting vulnerability in Discourse Discourse, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27154 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2025.12.2, 2026.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27154/ (Markdown: https://insights.sbomify.com/CVE-2026-27154/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27154
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27154
- OSV: https://osv.dev/vulnerability/CVE-2026-27154

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27154/
Summaries are generated and may contain mistakes; the official description above is the record.
