CVE-2026-27162 DIscourse doesn't prevent whispers to leak in excerpts

Medium 4.9 Published Updated

Attackers can view private whisper posts in excerpts due to improper access control checks in the posts_nearby function.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27162?

CVE-2026-27162 is a medium-severity vulnerability in Discourse Discourse, published on 26 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, `posts_nearby` was checking topic access but then returning all posts regardless of type, including whispers that should only be visible to whisperers. Use `Post.secured(guardian)` to properly filter post types based on user permissions. Versions 2025.12.2, 2026.1.1, and 2026.2.0 patch the issue. No known workarounds are available.

Weakness: CWE-200

Which versions are affected by CVE-2026-27162?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2025.12.2, 2026.1.1

Products include Discourse Discourse.

How do I fix CVE-2026-27162?

Upgrade discourse to a fixed version for your release line: 2025.12.2 or 2026.1.1.

Is CVE-2026-27162 being exploited?

There is no known exploitation of CVE-2026-27162 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2026-27162, GHSA-gffm-43j4-372w.

Is CVE-2026-27162 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free