# CVE-2026-27166: Discourse vulnerable to HTML injection via prohibited iframe URLs

> Attackers can inject HTML via iframe URLs in Discourse, potentially executing scripts or bypassing security controls.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Mar 2026
- **Updated:** 21 Mar 2026
- **Also known as:** BIT-discourse-2026-27166, GHSA-h653-cq78-vjj2

## What is CVE-2026-27166?

CVE-2026-27166 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 19 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1 and  2026.1.2, insufficient cleanup in the default Codepen allowed iframes value allows an attacker to trick a user into changing the URL of the main page. This issue has been fixed in versions 2026.3.0-latest.1, 2026.2.1 and  2026.1.2. To workaround this issue, remove Codepen from the list of allowed iframes.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-27166?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | From 2026.1.0 | 2026.1.2, 2026.2.1, 2026.3.0 |

Products: Discourse Discourse.

## How do I fix CVE-2026-27166?

Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.

## Is CVE-2026-27166 being exploited?

There is no known exploitation of CVE-2026-27166 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27166 and fix it if it is affected.

What it is: CVE-2026-27166 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 19 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27166 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected from 2026.1.0; fixed in 2026.1.2, 2026.2.1, 2026.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27166/ (Markdown: https://insights.sbomify.com/CVE-2026-27166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27166
- OSV: https://osv.dev/vulnerability/CVE-2026-27166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27166/
Summaries are generated and may contain mistakes; the official description above is the record.
