# CVE-2026-27172: Apache Camel-Consul component vulnerable to Deserialization of Untrusted Data

> An attacker with write access to the Consul KV store can inject malicious serialized objects to achieve arbitrary code execution in Apache Camel applications.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-5rc6-9qfp-8vwg

## What is CVE-2026-27172?

CVE-2026-27172 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The ConsulRegistry in the camel-consul component (class org.apache.camel.component.consul.ConsulRegistry and its inner ConsulRegistryUtils.deserialize method) read Java-serialized values from the Consul KV store and passed them to ObjectInputStream.readObject() without configuring an ObjectInputFilter. An attacker who can write to the Consul KV store backing a Camel ConsulRegistry instance could inject a malicious serialized Java object that is deserialized the next time Camel performs a lookup against that registry, leading to arbitrary code execution in the Camel process. The issue mirrors the class of vulnerability already addressed for other Camel components in CVE-2024-22369, CVE-2024-23114 and CVE-2026-25747, and was overlooked during the original remediation of those CVEs.

This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.1.

Users are recommended to upgrade to version 4.19.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.1.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-27172?

4 open source packages ship an affected version, including org.apache.camel:camel-consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-consul` | Maven | From 3.0.0 | 4.14.6 |
| `org.apache.camel:camel-consul` | Maven | From 3.0.0 | 4.14.6 |
| `org.apache.camel:camel-consul` | Maven | From 4.15.0 | 4.18.1 |
| `org.apache.camel:camel-consul` | Maven | From 4.15.0 | 4.18.1 |

Products: Apache Camel.

## How do I fix CVE-2026-27172?

Upgrade org.apache.camel:camel-consul to a fixed version for your release line: 4.14.6 or 4.18.1.

## Is CVE-2026-27172 being exploited?

There is no known exploitation of CVE-2026-27172 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-27172: Apache Camel camel-consul ConsulRegistry Java deserialization (RCE) (github_poc): https://github.com/oscerd/CVE-2026-27172

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27172 and fix it if it is affected.

What it is: CVE-2026-27172 is a high-severity unsafe deserialization vulnerability in Apache Camel, published on 27 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27172 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-consul (Maven): affected from 3.0.0; fixed in 4.14.6
- org.apache.camel:camel-consul (Maven): affected from 3.0.0; fixed in 4.14.6
- org.apache.camel:camel-consul (Maven): affected from 4.15.0; fixed in 4.18.1
- org.apache.camel:camel-consul (Maven): affected from 4.15.0; fixed in 4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27172/ (Markdown: https://insights.sbomify.com/CVE-2026-27172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27172
- OSV: https://osv.dev/vulnerability/CVE-2026-27172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27172/
Summaries are generated and may contain mistakes; the official description above is the record.
