# CVE-2026-27191: Feathers: Open Redirect in OAuth callback enables account takeover

> Attackers can steal access tokens via URL authority injection in OAuth callbacks, leading to full account takeover in Feathers.js applications.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Feb 2026
- **Updated:** 25 Feb 2026
- **Also known as:** GHSA-ppf9-4ffw-hh4p

## What is CVE-2026-27191?

CVE-2026-27191 is a high-severity vulnerability in feathersjs feathers, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Feathersjs is a framework for creating web APIs and real-time applications with TypeScript or JavaScript. Versions 5.0.39 and below the redirect query parameter is appended to the base origin without validation, allowing attackers to steal access tokens via URL authority injection. This leads to full account takeover, as the attacker obtains the victim's access token and can impersonate them. The application constructs the final redirect URL by concatenating the base origin with the user-supplied redirect parameter. This is exploitable when the origins array is configured and origin values do not end with /. An attacker can supply @attacker.com as the redirect value results in https://target.com@attacker.com#access_token=..., where the browser interprets attacker.com as the host, leading to full account takeover. This issue has been fixed in version 5.0.40.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-27191?

2 open source packages ship an affected version, including @feathersjs/authentication-oauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@feathersjs/authentication-oauth` | npm | All versions | 5.0.40 |
| `@feathersjs/authentication-oauth` | npm | All versions | 5.0.40 |

Products: Feathersjs Feathers.

## How do I fix CVE-2026-27191?

Upgrade @feathersjs/authentication-oauth to 5.0.40 or later.

## Is CVE-2026-27191 being exploited?

There is no known exploitation of CVE-2026-27191 in the wild and no public exploit code.

## Other vulnerabilities in feathersjs feathers

- [CVE-2026-29792](https://insights.sbomify.com/CVE-2026-29792/): Feathersjs has an OAuth Callback Account Takeover (critical 9.3)
- [CVE-2026-29793](https://insights.sbomify.com/CVE-2026-29793/): NoSQL Injection via WebSocket id Parameter in MongoDB Adapter (critical 9.3)
- [CVE-2026-27193](https://insights.sbomify.com/CVE-2026-27193/): Feathers exposes internal headers via unencrypted session cookie (high 8.2)
- [CVE-2026-27192](https://insights.sbomify.com/CVE-2026-27192/): Feathers has an origin validation bypass via prefix matching (high 7.6)
- [CVE-2023-37899](https://insights.sbomify.com/CVE-2023-37899/): feathersjs socket handler allows abusing implicit toString (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27191 and fix it if it is affected.

What it is: CVE-2026-27191 is a high-severity vulnerability in feathersjs feathers, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-27191 in the wild and no public exploit code.

Affected packages and fixed versions:
- @feathersjs/authentication-oauth (npm): affected all versions; fixed in 5.0.40
- @feathersjs/authentication-oauth (npm): affected all versions; fixed in 5.0.40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27191/ (Markdown: https://insights.sbomify.com/CVE-2026-27191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27191
- OSV: https://osv.dev/vulnerability/CVE-2026-27191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27191/
Summaries are generated and may contain mistakes; the official description above is the record.
