CVE-2026-27192 Feathers has an origin validation bypass via prefix matching

High 7.6 Published Updated

Attackers can bypass origin validation via prefix matching to exfiltrate OAuth tokens and achieve account takeover in FeathersJS applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-27192?

CVE-2026-27192 is a high-severity vulnerability in feathersjs feathers, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Feathersjs is a framework for creating web APIs and real-time applications with TypeScript or JavaScript. In versions 5.0.39 and below, origin validation uses startsWith() for comparison, allowing attackers to bypass the check by registering a domain that shares a common prefix with an allowed origin.The getAllowedOrigin() function checks if the Referer header starts with any allowed origin, and this comparison is insufficient as it only validates the prefix. This is exploitable when the origins array is configured and an attacker registers a domain starting with an allowed origin string (e.g., https://target.com.attacker.com bypasses https://target.com). On its own, tokens are still redirected to a configured origin. However, in specific scenarios an attacker can initiate the OAuth flow from an unauthorized origin and exfiltrate tokens, achieving full account takeover. This issue has bee fixed in version 5.0.40.

Weakness: CWE-346

Which versions are affected by CVE-2026-27192?

2 open source packages ship an affected version, including @feathersjs/authentication-oauth. It affects 1 product.

PackageAffectedFixed in
@feathersjs/authentication-oauth npmAll versions5.0.40
@feathersjs/authentication-oauth npmAll versions5.0.40

Products include Feathersjs Feathers.

How do I fix CVE-2026-27192?

Upgrade @feathersjs/authentication-oauth to 5.0.40 or later.

Is CVE-2026-27192 being exploited?

There is no known exploitation of CVE-2026-27192 in the wild and no public exploit code.

Sources

Also known as GHSA-mp4x-c34x-wv3x.

Is CVE-2026-27192 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free