CVE-2026-27197 Sentry: Improper Authentication on SAML SSO process allows user identity linking
Attackers can take over user accounts via malicious SAML SSO in multi-organization Sentry instances, requiring upgrade or 2FA.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27197?
CVE-2026-27197 is a critical authentication bypass vulnerability in getsentry sentry, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sentry is a developer-first error tracking and performance monitoring tool. Versions 21.12.0 through 26.1.0 have a critical vulnerability in its SAML SSO implementation which allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. Self-hosted users are only at risk if the following criteria is met: ore than one organizations are configured (SENTRY_SINGLE_ORGANIZATION = True), or malicious user has existing access and permissions to modify SSO settings for another organization in a multo-organization instance. This issue has been fixed in version 26.2.0. To workaround this issue, implement user account-based two-factor authentication to prevent an attacker from being able to complete authentication with a victim's user account. Organization administrators cannot do this on a user's behalf, this requires individual users to ensure 2FA has been enabled for their account.
Weakness: CWE-287
Which versions are affected by CVE-2026-27197?
3 open source packages ship an affected version, including sentry. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
sentry PyPI | From 21.12.0 | None |
sentry PyPI | From 21.12.0 | None |
sentry PyPI | From 21.12.0 | 26.2.0 |
Products include Sentry Sentry.
How do I fix CVE-2026-27197?
Upgrade sentry to 26.2.0 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-27197 being exploited?
There is no known exploitation of CVE-2026-27197 in the wild and no public exploit code.
Other vulnerabilities in getsentry sentry
- CVE-2026-42354 Sentry: Improper authentication on SAML SSO process allows user identity linking
- CVE-2021-47935 Sentry 8.2.0 Remote Code Execution via Pickle Deserialization
- CVE-2023-39349 Sentry vulnerable to privilege escalation via ApiTokensEndpoint
- CVE-2023-36826 Sentry vulnerable to improper authorization on debug and artifact file downloads
- CVE-2026-52794 Sentry: Inefficient Regular Expression Complexity in sentry
Sources
Also known as GHSA-ggmg-cqg6-j45g, PYSEC-2026-533.