{"answers":{"affected":"3 open source packages ship an affected version, including sentry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27197 in the wild and no public exploit code.","fix":"Upgrade sentry to 26.2.0 or later.","what":"CVE-2026-27197 is a critical authentication bypass vulnerability in getsentry sentry, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27197 and fix it if it is affected.\n\nWhat it is: CVE-2026-27197 is a critical authentication bypass vulnerability in getsentry sentry, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27197 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sentry (PyPI): affected from 21.12.0; no fix listed\n- sentry (PyPI): affected from 21.12.0; no fix listed\n- sentry (PyPI): affected from 21.12.0; fixed in 26.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27197/ (Markdown: https://insights.sbomify.com/CVE-2026-27197/index.md)","id":"CVE-2026-27197","markdown":"https://insights.sbomify.com/CVE-2026-27197/index.md","name":"CVE-2026-27197","record":{"aliases":["GHSA-ggmg-cqg6-j45g","PYSEC-2026-533"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Sentry error tracking","requires_auth":"none","summary":"Attackers can take over user accounts via malicious SAML SSO in multi-organization Sentry instances, requiring upgrade or 2FA.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sentry","vendor":"sentry"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Sentry is a developer-first error tracking and performance monitoring tool. Versions 21.12.0 through 26.1.0 have a critical vulnerability in its SAML SSO implementation  which allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. Self-hosted users are only at risk if the following criteria is met: ore than one organizations are configured (SENTRY_SINGLE_ORGANIZATION = True), or malicious user has existing access and permissions to modify SSO settings for another organization in a multo-organization instance. This issue has been fixed in version 26.2.0. To workaround this issue, implement user account-based two-factor authentication to prevent an attacker from being able to complete authentication with a victim's user account. Organization administrators cannot do this on a user's behalf, this requires individual users to ensure 2FA has been enabled for their account.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sentry: Improper Authentication on SAML SSO process allows user identity linking","id":"CVE-2026-27197","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Formwork Improperly Manages Privileges During User Creation","id":"CVE-2026-27198"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["21.12.0"],"last_affected":[],"package":"sentry","purl":null,"source":"GHSA-ggmg-cqg6-j45g"},{"ecosystem":"PyPI","fixed":[],"introduced":["21.12.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"GHSA-ggmg-cqg6-j45g"},{"ecosystem":"PyPI","fixed":["26.2.0"],"introduced":["21.12.0"],"last_affected":[],"package":"sentry","purl":"pkg:pypi/sentry","source":"PYSEC-2026-533"}],"prev":{"headline":"Statamic affected by privilege escalation via stored Cross-site Scripting","id":"CVE-2026-27196"},"products":["sentry"],"published":"2026-02-21","related":[{"cvss_score":9.1,"headline":"Sentry: Improper authentication on SAML SSO process allows user identity linking","id":"CVE-2026-42354","kev_date_added":null,"published":"2026-05-08"},{"cvss_score":8.7,"headline":"Sentry 8.2.0 Remote Code Execution via Pickle Deserialization","id":"CVE-2021-47935","kev_date_added":null,"published":"2026-05-10"},{"cvss_score":8.1,"headline":"Sentry vulnerable to privilege escalation via ApiTokensEndpoint","id":"CVE-2023-39349","kev_date_added":null,"published":"2023-08-07"},{"cvss_score":7.7,"headline":"Sentry vulnerable to improper authorization on debug and artifact file downloads","id":"CVE-2023-36826","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":7.5,"headline":"Sentry: Inefficient Regular Expression Complexity in sentry","id":"CVE-2026-52794","kev_date_added":null,"published":"2026-06-24"},{"cvss_score":7.3,"headline":"Sentry's superuser cleartext password leaked in logs","id":"CVE-2024-32474","kev_date_added":null,"published":"2024-04-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-02-24","vendors":["getsentry"]},"summary":"Attackers can take over user accounts via malicious SAML SSO in multi-organization Sentry instances, requiring upgrade or 2FA.","url":"https://insights.sbomify.com/CVE-2026-27197/"}