# CVE-2026-27197: Sentry: Improper Authentication on SAML SSO process allows user identity linking

> Attackers can take over user accounts via malicious SAML SSO in multi-organization Sentry instances, requiring upgrade or 2FA.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-ggmg-cqg6-j45g, PYSEC-2026-533

## What is CVE-2026-27197?

CVE-2026-27197 is a critical authentication bypass vulnerability in getsentry sentry, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sentry is a developer-first error tracking and performance monitoring tool. Versions 21.12.0 through 26.1.0 have a critical vulnerability in its SAML SSO implementation  which allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. Self-hosted users are only at risk if the following criteria is met: ore than one organizations are configured (SENTRY_SINGLE_ORGANIZATION = True), or malicious user has existing access and permissions to modify SSO settings for another organization in a multo-organization instance. This issue has been fixed in version 26.2.0. To workaround this issue, implement user account-based two-factor authentication to prevent an attacker from being able to complete authentication with a victim's user account. Organization administrators cannot do this on a user's behalf, this requires individual users to ensure 2FA has been enabled for their account.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-27197?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 21.12.0 | None |
| `sentry` | PyPI | From 21.12.0 | None |
| `sentry` | PyPI | From 21.12.0 | 26.2.0 |

Products: Sentry Sentry.

## How do I fix CVE-2026-27197?

Upgrade sentry to 26.2.0 or later.

## Is CVE-2026-27197 being exploited?

There is no known exploitation of CVE-2026-27197 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)
- [CVE-2026-52794](https://insights.sbomify.com/CVE-2026-52794/): Sentry: Inefficient Regular Expression Complexity in sentry (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27197 and fix it if it is affected.

What it is: CVE-2026-27197 is a critical authentication bypass vulnerability in getsentry sentry, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27197 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 21.12.0; no fix listed
- sentry (PyPI): affected from 21.12.0; no fix listed
- sentry (PyPI): affected from 21.12.0; fixed in 26.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27197/ (Markdown: https://insights.sbomify.com/CVE-2026-27197/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27197
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27197
- OSV: https://osv.dev/vulnerability/CVE-2026-27197

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27197/
Summaries are generated and may contain mistakes; the official description above is the record.
