# CVE-2026-27198: Formwork Improperly Manages Privileges During User Creation

> An authenticated editor can create admin accounts due to missing authorization checks, leading to full CMS compromise.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** GHSA-34p4-7w83-35g2

## What is CVE-2026-27198?

CVE-2026-27198 is a high-severity vulnerability in getformwork formwork, published on 21 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Formwork is a flat file-based Content Management System (CMS). In versions 2.0.0 through 2.3.3, the application fails to properly enforce role-based authorization during account creation. Although the system validates that the specified role exists, it does not verify whether the current user has sufficient privileges to assign highly privileged roles such as admin. As a result, an authenticated user with the editor role can create a new account with administrative privileges, leading to full administrative access and complete compromise of the CMS. This issue has been fixed in version 2.3.4.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-27198?

2 open source packages ship an affected version, including getformwork/formwork. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getformwork/formwork` | Packagist | From 2.0.0 | 2.3.4 |
| `getformwork/formwork` | Packagist | From 2.0.0 | 2.3.4 |

Products: Formwork Project Formwork.

## How do I fix CVE-2026-27198?

Upgrade getformwork/formwork to 2.3.4 or later.

## Is CVE-2026-27198 being exploited?

There is no known exploitation of CVE-2026-27198 in the wild and no public exploit code.

## Other vulnerabilities in getformwork formwork

- [CVE-2025-65956](https://insights.sbomify.com/CVE-2025-65956/): Formwork CMS Has a Stored Cross-Site Scripting (XSS) Vulnerability in Blog Tags (medium 6.5)
- [CVE-2024-37160](https://insights.sbomify.com/CVE-2024-37160/): Formwork has a Cross-site scripting (XSS) vulnerability in Description metadata (medium 4.8)
- [CVE-2023-24230](https://insights.sbomify.com/CVE-2023-24230/): Formwork Cross-site Scripting (XSS) from Page title field (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27198 and fix it if it is affected.

What it is: CVE-2026-27198 is a high-severity vulnerability in getformwork formwork, published on 21 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27198 in the wild and no public exploit code.

Affected packages and fixed versions:
- getformwork/formwork (Packagist): affected from 2.0.0; fixed in 2.3.4
- getformwork/formwork (Packagist): affected from 2.0.0; fixed in 2.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27198/ (Markdown: https://insights.sbomify.com/CVE-2026-27198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27198
- OSV: https://osv.dev/vulnerability/CVE-2026-27198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27198/
Summaries are generated and may contain mistakes; the official description above is the record.
