# CVE-2026-27206: Zumba Json Serializer has a potential PHP Object Injection via Unrestricted @type in unserialize()

> Attackers can achieve remote code execution by injecting malicious JSON into the Zumba Json Serializer library if untrusted input is deserialized.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** DEBIAN-CVE-2026-27206, GHSA-v7m3-fpcr-h7m2, UBUNTU-CVE-2026-27206

## What is CVE-2026-27206?

CVE-2026-27206 is a high-severity unsafe deserialization vulnerability in zumba json-serializer, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zumba Json Serializer is a library to serialize PHP variables in JSON format. In versions 3.2.2 and below, the library allows deserialization of PHP objects from JSON using a special @type field. The deserializer instantiates any class specified in the @type field without restriction. When processing untrusted JSON input, this behavior may allow an attacker to instantiate arbitrary classes available in the application. If a vulnerable application passes attacker-controlled JSON into JsonSerializer::unserialize() and contains classes with dangerous magic methods (such as __wakeup() or __destruct()), this may lead to PHP Object Injection and potentially Remote Code Execution (RCE), depending on available gadget chains in the application or its dependencies. This behavior is similar in risk profile to PHP's native unserialize() when used without the allowed_classes restriction. Applications are impacted only if untrusted or attacker-controlled JSON is passed into JsonSerializer::unserialize() and the application or its dependencies contain classes that can be leveraged as a gadget chain. This issue has been fixed in version 3.2.3. If an immediate upgrade isn't feasible, mitigate the vulnerability by never deserializing untrusted JSON with JsonSerializer::unserialize(), validating and sanitizing all JSON input before deserialization, and disabling @type-based object instantiation wherever possible.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-27206?

2 open source packages ship an affected version, including zumba/json-serializer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zumba/json-serializer` | Packagist | All versions | 3.2.3 |
| `zumba/json-serializer` | Packagist | All versions | 3.2.3 |

## How do I fix CVE-2026-27206?

Upgrade zumba/json-serializer to 3.2.3 or later.

## Is CVE-2026-27206 being exploited?

There is no known exploitation of CVE-2026-27206 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27206 and fix it if it is affected.

What it is: CVE-2026-27206 is a high-severity unsafe deserialization vulnerability in zumba json-serializer, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27206 in the wild and no public exploit code.

Affected packages and fixed versions:
- zumba/json-serializer (Packagist): affected all versions; fixed in 3.2.3
- zumba/json-serializer (Packagist): affected all versions; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27206/ (Markdown: https://insights.sbomify.com/CVE-2026-27206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27206
- OSV: https://osv.dev/vulnerability/CVE-2026-27206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27206/
Summaries are generated and may contain mistakes; the official description above is the record.
