{"answers":{"affected":"2 open source packages ship an affected version, including pannellum. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27210 in the wild and no public exploit code.","fix":"Upgrade pannellum to 2.5.7 or later.","what":"CVE-2026-27210 is a medium-severity cross-site scripting vulnerability in mpetroff pannellum, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-27210 and fix it if it is affected.\n\nWhat it is: CVE-2026-27210 is a medium-severity cross-site scripting vulnerability in mpetroff pannellum, published on 21 Feb 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-27210 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pannellum (npm): affected from 2.5.0; fixed in 2.5.7\n- pannellum (npm): affected from 2.5.0; fixed in 2.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27210/ (Markdown: https://insights.sbomify.com/CVE-2026-27210/index.md)","id":"CVE-2026-27210","markdown":"https://insights.sbomify.com/CVE-2026-27210/index.md","name":"CVE-2026-27210","record":{"aliases":["GHSA-8423-w5wx-h2r6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Pannellum panorama viewer","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via malicious hotspot attributes in Pannellum, potentially leading to account takeover or page defacement.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pannellum","vendor":"pannellum"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pannellum is a lightweight, free, and open source panorama viewer for the web. In versions 3.5.0 through 2.5.6, the hot spot attributes configuration property allowed any attribute to be set, including HTML event handler attributes, allowing for potential XSS attacks. This affects websites hosting the standalone viewer HTML file and any other use of untrusted JSON config files (bypassing the protections of the escapeHTML parameter). As certain events fire without any additional user interaction, visiting a standalone viewer URL that points to a malicious config file — without additional user interaction — is sufficient to trigger the vulnerability and execute arbitrary JavaScript code, which can, for example, replace the contents of the page with arbitrary content and make it appear to be hosted by the website hosting the standalone viewer HTML file. This issue has been fixed in version 2.5.7. To workaround, setting the Content-Security-Policy header to script-src-attr 'none' will block execution of inline event handlers, mitigating this vulnerability. Don't host pannellum.htm on a domain that shares cookies with user authentication to mitigate XSS risk.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pannellum has a XSS vulnerability in hot spot attributes","id":"CVE-2026-27210","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Cloud Hypervisor: Host File Exfiltration via QCOW Backing File Abuse","id":"CVE-2026-27211"},"packages":[{"ecosystem":"npm","fixed":["2.5.7"],"introduced":["2.5.0"],"last_affected":[],"package":"pannellum","purl":null,"source":"GHSA-8423-w5wx-h2r6"},{"ecosystem":"npm","fixed":["2.5.7"],"introduced":["2.5.0"],"last_affected":[],"package":"pannellum","purl":"pkg:npm/pannellum","source":"GHSA-8423-w5wx-h2r6"}],"prev":{"headline":"api-gateway-deploy Affected by Exploitable Command Injection via Unprivileged Root Execution","id":"CVE-2026-27208"},"products":["pannellum"],"published":"2026-02-21","related":[{"cvss_score":4.8,"headline":"XSS in Pannellum from 2.5.0 through 2.5.4","id":"CVE-2019-16763","kev_date_added":null,"published":"2019-11-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-25","vendors":["mpetroff"]},"summary":"Attackers can execute arbitrary JavaScript via malicious hotspot attributes in Pannellum, potentially leading to account takeover or page defacement.","url":"https://insights.sbomify.com/CVE-2026-27210/"}