CVE-2026-2728 LibreNMS: Cross-Site Scripting in ShowConfigController

Medium 4.6 Published Updated

Authenticated attackers with admin privileges can inject scripts into the showconfig page, potentially compromising other users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-2728?

CVE-2026-2728 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 13 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

LibreNMS versions before 26.3.0 are affected by an authenticated Cross-site Scripting vulnerability on the showconfig page. Successful exploitation requires administrative privileges. Exploitation could result in XSS attacks being performed against other users with access to the page.

Weakness: CWE-79

Which versions are affected by CVE-2026-2728?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.

PackageAffectedFixed in
librenms/librenms PackagistFrom 25.12.026.3.0
librenms/librenms PackagistFrom 25.12.026.3.0

Products include Librenms Librenms.

How do I fix CVE-2026-2728?

Upgrade librenms/librenms to 26.3.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-2728 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2728 exists.

All Librenms Librenms vulnerabilities

Sources

Also known as GHSA-5gm9-622f-qcg5.

Is CVE-2026-2728 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free