CVE-2026-27314 Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass

High 8.8 Published Updated

A user with CREATE permission can escalate privileges to superuser by associating their certificate with an arbitrary role in mTLS environments.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-27314?

CVE-2026-27314 is a high-severity vulnerability in Apache Cassandra, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY.

Users are recommended to upgrade to version 5.0.7+, which fixes this issue.

Weakness: CWE-267

Which versions are affected by CVE-2026-27314?

2 open source packages ship an affected version, including org.apache.cassandra:cassandra-all. It affects 1 product.

PackageAffectedFixed in
org.apache.cassandra:cassandra-all MavenFrom 5.0-alpha15.0.7
org.apache.cassandra:cassandra-all MavenFrom 5.0-alpha15.0.7

Products include Apache Cassandra.

How do I fix CVE-2026-27314?

Upgrade org.apache.cassandra:cassandra-all to 5.0.7 or later.

Is CVE-2026-27314 being exploited?

There is no known exploitation of CVE-2026-27314 in the wild and no public exploit code.

Sources

Also known as AZL-82676, GHSA-qxpc-96fq-wwmg, ROOT-APP-MAVEN-CVE-2026-27314.

Is CVE-2026-27314 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free