{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.cassandra:cassandra-all. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-27314 in the wild and no public exploit code.","fix":"Upgrade org.apache.cassandra:cassandra-all to 5.0.7 or later.","what":"CVE-2026-27314 is a high-severity vulnerability in Apache Cassandra, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-27314 and fix it if it is affected.\n\nWhat it is: CVE-2026-27314 is a high-severity vulnerability in Apache Cassandra, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-27314 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-alpha1; fixed in 5.0.7\n- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-alpha1; fixed in 5.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-27314/ (Markdown: https://insights.sbomify.com/CVE-2026-27314/index.md)","id":"CVE-2026-27314","markdown":"https://insights.sbomify.com/CVE-2026-27314/index.md","name":"CVE-2026-27314","record":{"aliases":["AZL-82676","GHSA-qxpc-96fq-wwmg","ROOT-APP-MAVEN-CVE-2026-27314"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Cassandra","requires_auth":"low_privilege","summary":"A user with CREATE permission can escalate privileges to superuser by associating their certificate with an arbitrary role in mTLS environments.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"cassandra","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-267","name":"Privilege Defined With Unsafe Actions"}],"description":"Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role,\nincluding a superuser role, and authenticate as that role via ADD IDENTITY.\n\nUsers are recommended to upgrade to version 5.0.7+, which fixes this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass","id":"CVE-2026-27314","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Apache Cassandra: cqlsh history sensitive information leak","id":"CVE-2026-27315"},"packages":[{"ecosystem":"Maven","fixed":["5.0.7"],"introduced":["5.0-alpha1"],"last_affected":[],"package":"org.apache.cassandra:cassandra-all","purl":null,"source":"GHSA-qxpc-96fq-wwmg"},{"ecosystem":"Maven","fixed":["5.0.7"],"introduced":["5.0-alpha1"],"last_affected":[],"package":"org.apache.cassandra:cassandra-all","purl":"pkg:maven/org.apache.cassandra/cassandra-all","source":"GHSA-qxpc-96fq-wwmg"}],"prev":{"headline":"Bridge | Heap-based Buffer Overflow (CWE-122)","id":"CVE-2026-27313"},"products":["Apache Cassandra"],"published":"2026-04-07","related":[{"cvss_score":9.8,"headline":"Oracle Java SE and JRockit Unspecified","id":"CVE-2016-3427","kev_date_added":"2023-05-12","published":"2016-04-21"},{"cvss_score":9.8,"headline":"Missing Authentication for Critical Function in Apache Cassandra","id":"CVE-2018-8016","kev_date_added":null,"published":"2018-06-28"},{"cvss_score":9.1,"headline":"Remote code execution for scripted UDFs","id":"CVE-2021-44521","kev_date_added":null,"published":"2022-02-11"},{"cvss_score":8.8,"headline":"Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)","id":"CVE-2025-26467","kev_date_added":null,"published":"2025-08-25"},{"cvss_score":8.8,"headline":"Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions","id":"CVE-2025-23015","kev_date_added":null,"published":"2025-02-04"},{"cvss_score":7.8,"headline":"Apache Cassandra: Privilege escalation when enabling FQL/Audit logs","id":"CVE-2023-30601","kev_date_added":null,"published":"2023-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["Apache Software Foundation"]},"summary":"A user with CREATE permission can escalate privileges to superuser by associating their certificate with an arbitrary role in mTLS environments.","url":"https://insights.sbomify.com/CVE-2026-27314/"}