# CVE-2026-27314: Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass

> A user with CREATE permission can escalate privileges to superuser by associating their certificate with an arbitrary role in mTLS environments.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** AZL-82676, GHSA-qxpc-96fq-wwmg, ROOT-APP-MAVEN-CVE-2026-27314

## What is CVE-2026-27314?

CVE-2026-27314 is a high-severity vulnerability in Apache Cassandra, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role,
including a superuser role, and authenticate as that role via ADD IDENTITY.

Users are recommended to upgrade to version 5.0.7+, which fixes this issue.

Weakness: CWE-267 (Privilege Defined With Unsafe Actions)

## Which versions are affected by CVE-2026-27314?

2 open source packages ship an affected version, including org.apache.cassandra:cassandra-all. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cassandra:cassandra-all` | Maven | From 5.0-alpha1 | 5.0.7 |
| `org.apache.cassandra:cassandra-all` | Maven | From 5.0-alpha1 | 5.0.7 |

Products: Apache Cassandra.

## How do I fix CVE-2026-27314?

Upgrade org.apache.cassandra:cassandra-all to 5.0.7 or later.

## Is CVE-2026-27314 being exploited?

There is no known exploitation of CVE-2026-27314 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cassandra

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2018-8016](https://insights.sbomify.com/CVE-2018-8016/): Missing Authentication for Critical Function in Apache Cassandra (critical 9.8)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)
- [CVE-2025-23015](https://insights.sbomify.com/CVE-2025-23015/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27314 and fix it if it is affected.

What it is: CVE-2026-27314 is a high-severity vulnerability in Apache Cassandra, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27314 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-alpha1; fixed in 5.0.7
- org.apache.cassandra:cassandra-all (Maven): affected from 5.0-alpha1; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27314/ (Markdown: https://insights.sbomify.com/CVE-2026-27314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27314
- OSV: https://osv.dev/vulnerability/CVE-2026-27314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27314/
Summaries are generated and may contain mistakes; the official description above is the record.
