# CVE-2026-27315: Apache Cassandra: cqlsh history sensitive information leak

> Attackers with local access can read cleartext passwords from cqlsh history files, exposing sensitive credentials stored by the database client.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** BIT-cassandra-2026-27315, CLEANSTART-2026-CL53248, CLEANSTART-2026-TJ88203, GHSA-fh34-c629-p8xj, MINI-ff7j-2765-8j2p, MINI-qxgw-5vf2-rxmm

## What is CVE-2026-27315?

CVE-2026-27315 is a medium-severity vulnerability in Apache Cassandra, published on 7 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Sensitive Information Leak in cqlsh in Apache Cassandra 4.0 allows access to sensitive information, like passwords, from previously executed cqlsh command via  ~/.cassandra/cqlsh_history local file access.

Users are recommended to upgrade to version 4.0.20, which fixes this issue.

--
Description: Cassandra's command-line tool, cqlsh, provides a command history feature that allows users to recall previously executed commands using the up/down arrow keys. These history records are saved in the ~/.cassandra/cqlsh_history file in the user's home directory.

However, cqlsh does not redact sensitive information when saving command history. This means that if a user executes operations involving passwords (such as logging in or creating users) within cqlsh, these passwords are permanently stored in cleartext in the history file on the disk.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-27315?

3 open source packages ship an affected version, including org.apache.cassandra:cassandra-all and cassandra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0 | 4.0.20 |
| `org.apache.cassandra:cassandra-all` | Maven | From 4.0 | 4.0.20 |
| `cassandra` | Bitnami | From 4.0.0 | 4.0.20 |

Products: Apache Cassandra.

## How do I fix CVE-2026-27315?

Upgrade org.apache.cassandra:cassandra-all to 4.0.20 or later.

## Is CVE-2026-27315 being exploited?

There is no known exploitation of CVE-2026-27315 in the wild and no public exploit code.

## Other vulnerabilities in Apache Cassandra

- [CVE-2016-3427](https://insights.sbomify.com/CVE-2016-3427/): Oracle Java SE and JRockit Unspecified (critical 9.8, exploited in the wild)
- [CVE-2018-8016](https://insights.sbomify.com/CVE-2018-8016/): Missing Authentication for Critical Function in Apache Cassandra (critical 9.8)
- [CVE-2021-44521](https://insights.sbomify.com/CVE-2021-44521/): Remote code execution for scripted UDFs (critical 9.1)
- [CVE-2026-27314](https://insights.sbomify.com/CVE-2026-27314/): Apache Cassandra: Privilege escalation via ADD IDENTITY authorization bypass (high 8.8)
- [CVE-2025-26467](https://insights.sbomify.com/CVE-2025-26467/): Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27315 and fix it if it is affected.

What it is: CVE-2026-27315 is a medium-severity vulnerability in Apache Cassandra, published on 7 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27315 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0; fixed in 4.0.20
- org.apache.cassandra:cassandra-all (Maven): affected from 4.0; fixed in 4.0.20
- cassandra (Bitnami): affected from 4.0.0; fixed in 4.0.20

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27315/ (Markdown: https://insights.sbomify.com/CVE-2026-27315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27315
- OSV: https://osv.dev/vulnerability/CVE-2026-27315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27315/
Summaries are generated and may contain mistakes; the official description above is the record.
