# CVE-2026-2734: Authorization Bypass in SearchModelVersions in mlflow/mlflow

> Authenticated users can bypass per-model authorization to enumerate all model versions and metadata in MLflow when basic authentication is enabled.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 21 May 2026
- **Also known as:** BIT-mlflow-2026-2734, CLSA-2026-1791447254, GHSA-w5xq-c4pf-ghq7, PYSEC-2026-2660

## What is CVE-2026-2734?

CVE-2026-2734 is a medium-severity missing authorization vulnerability in Lfprojects Mlflow, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In mlflow/mlflow versions up to 3.9.0, the `SearchModelVersions` REST API endpoint and the `mlflowSearchModelVersions` GraphQL query lack proper per-model authorization checks when basic authentication is enabled. This allows any authenticated user to enumerate all model versions across all registered models, regardless of their permission level. The issue arises due to the absence of `SearchModelVersions` in the `BEFORE_REQUEST_VALIDATORS` and `AFTER_REQUEST_HANDLERS` for the REST API, and its omission from `GraphQLAuthorizationMiddleware.PROTECTED_FIELDS` for GraphQL. This vulnerability can expose sensitive information such as model names, version descriptions, source URIs, tags, and other metadata, potentially revealing proprietary or confidential details in multi-tenant environments. The issue is resolved in version 3.10.0.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-2734?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |
| `mlflow` | PyPI | All versions | 3.10.0 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2026-2734?

Upgrade mlflow to 3.10.0 or later.

## Is CVE-2026-2734 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2734 exists.

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2734 and fix it if it is affected.

What it is: CVE-2026-2734 is a medium-severity missing authorization vulnerability in Lfprojects Mlflow, published on 21 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2734 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0
- mlflow (PyPI): affected all versions; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2734/ (Markdown: https://insights.sbomify.com/CVE-2026-2734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2734
- OSV: https://osv.dev/vulnerability/CVE-2026-2734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2734/
Summaries are generated and may contain mistakes; the official description above is the record.
