CVE-2026-2741 Zip Slip Path Traversal on Node Unpack
Attackers can execute arbitrary code or modify files by serving malicious ZIP archives during automatic Node.js extraction in Vaadin applications.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-2741?
CVE-2026-2741 is a low-severity path traversal vulnerability in vaadin flow, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Specially crafted ZIP archives can escape the intended extraction directory during Node.js download and extraction in Vaadin 14.2.0 through 14.14.0, 15.0.0 through 23.6.6, 24.0.0 through 24.9.8, and 25.0.0 through 25.0.2.
Vaadin’s build process can automatically download and extract Node.js if it is not installed locally. If an attacker can intercept or control this download via DNS hijacking, a MITM attack, a compromised mirror, or a supply chain attack, they can serve a malicious archive containing path traversal sequences that write files outside the intended extraction directory.
Users of affected versions should use a globally preinstalled Node.js version compatible with their Vaadin version, or upgrade as follows: 14.2.0-14.14.0 to 14.14.1, 15.0.0-23.6.6 to 23.6.7, 24.0.0-24.9.8 to 24.9.9, and 25.0.0-25.0.2 to 25.0.3 or newer.
Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.
Weakness: CWE-22
Which versions are affected by CVE-2026-2741?
8 open source packages ship an affected version, including com.vaadin:flow-project. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.vaadin:flow-project Maven | From 14.2.0 | 14.14.1 |
com.vaadin:flow-project Maven | From 14.2.0 | 14.14.1 |
com.vaadin:flow-project Maven | From 23.0.0 | 23.6.7 |
com.vaadin:flow-project Maven | From 23.0.0 | 23.6.7 |
com.vaadin:flow-project Maven | From 24.0.0 | 24.9.9 |
com.vaadin:flow-project Maven | From 24.0.0 | 24.9.9 |
2 more packages
com.vaadin:flow-project Maven | From 25.0.0 | 25.0.3 |
com.vaadin:flow-project Maven | From 25.0.0 | 25.0.3 |
Products include Vaadin Vaadin.
How do I fix CVE-2026-2741?
Upgrade com.vaadin:flow-project to a fixed version for your release line: 14.14.1, 23.6.7, 24.9.9 or 25.0.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-2741 being exploited?
There is no known exploitation of CVE-2026-2741 in the wild and no public exploit code.
Other vulnerabilities in vaadin flow
- CVE-2021-31409 Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19
- CVE-2020-36320 Regular expression Denial of Service (ReDoS) in EmailValidator class in Vaadin 7
- CVE-2021-33611 Reflected cross-site scripting in vaadin-menu-bar webjar resources in Vaadin 14
- CVE-2023-25499 Possible information disclosure in non visible components
- CVE-2022-29567 Possible information disclosure inside TreeGrid component with default data provider
Sources
Also known as GHSA-8jrh-7jg8-fvmv.