# CVE-2026-2741: Zip Slip Path Traversal on Node Unpack

> Attackers can execute arbitrary code or modify files by serving malicious ZIP archives during automatic Node.js extraction in Vaadin applications.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/S:N/AU:N/R:U/V:D/RE:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2026
- **Updated:** 16 Mar 2026
- **Also known as:** GHSA-8jrh-7jg8-fvmv

## What is CVE-2026-2741?

CVE-2026-2741 is a low-severity path traversal vulnerability in vaadin flow, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Specially crafted ZIP archives can escape the intended extraction directory during Node.js download and extraction in Vaadin 14.2.0 through 14.14.0, 15.0.0 through 23.6.6, 24.0.0 through 24.9.8, and 25.0.0 through 25.0.2. 

Vaadin’s build process can automatically download and extract Node.js if it is not installed locally. If an attacker can intercept or control this download via DNS hijacking, a MITM attack, a compromised mirror, or a supply chain attack, they can serve a malicious archive containing path traversal sequences that write files outside the intended extraction directory.

Users of affected versions should use a globally preinstalled Node.js version compatible with their Vaadin version, or upgrade as follows: 14.2.0-14.14.0 to 14.14.1, 15.0.0-23.6.6 to 23.6.7, 24.0.0-24.9.8 to 24.9.9, and 25.0.0-25.0.2 to 25.0.3 or newer.

Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-2741?

8 open source packages ship an affected version, including com.vaadin:flow-project. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.vaadin:flow-project` | Maven | From 14.2.0 | 14.14.1 |
| `com.vaadin:flow-project` | Maven | From 14.2.0 | 14.14.1 |
| `com.vaadin:flow-project` | Maven | From 23.0.0 | 23.6.7 |
| `com.vaadin:flow-project` | Maven | From 23.0.0 | 23.6.7 |
| `com.vaadin:flow-project` | Maven | From 24.0.0 | 24.9.9 |
| `com.vaadin:flow-project` | Maven | From 24.0.0 | 24.9.9 |
| `com.vaadin:flow-project` | Maven | From 25.0.0 | 25.0.3 |
| `com.vaadin:flow-project` | Maven | From 25.0.0 | 25.0.3 |

Products: Vaadin Vaadin.

## How do I fix CVE-2026-2741?

Upgrade com.vaadin:flow-project to a fixed version for your release line: 14.14.1, 23.6.7, 24.9.9 or 25.0.3.

## Is CVE-2026-2741 being exploited?

There is no known exploitation of CVE-2026-2741 in the wild and no public exploit code.

## Other vulnerabilities in vaadin flow

- [CVE-2021-31409](https://insights.sbomify.com/CVE-2021-31409/): Server session is not invalidated when logout() helper method of Authentication module is used in Vaadin 18-19 (high 7.5)
- [CVE-2020-36320](https://insights.sbomify.com/CVE-2020-36320/): Regular expression Denial of Service (ReDoS) in EmailValidator class in Vaadin 7 (high 7.5)
- [CVE-2021-33611](https://insights.sbomify.com/CVE-2021-33611/): Reflected cross-site scripting in vaadin-menu-bar webjar resources in Vaadin 14 (medium 6.1)
- [CVE-2023-25499](https://insights.sbomify.com/CVE-2023-25499/): Possible information disclosure in non visible components (medium 5.7)
- [CVE-2022-29567](https://insights.sbomify.com/CVE-2022-29567/): Possible information disclosure inside TreeGrid component with default data provider (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-2741 and fix it if it is affected.

What it is: CVE-2026-2741 is a low-severity path traversal vulnerability in vaadin flow, published on 10 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-2741 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.vaadin:flow-project (Maven): affected from 14.2.0; fixed in 14.14.1
- com.vaadin:flow-project (Maven): affected from 14.2.0; fixed in 14.14.1
- com.vaadin:flow-project (Maven): affected from 23.0.0; fixed in 23.6.7
- com.vaadin:flow-project (Maven): affected from 23.0.0; fixed in 23.6.7
- com.vaadin:flow-project (Maven): affected from 24.0.0; fixed in 24.9.9
- com.vaadin:flow-project (Maven): affected from 24.0.0; fixed in 24.9.9
- com.vaadin:flow-project (Maven): affected from 25.0.0; fixed in 25.0.3
- com.vaadin:flow-project (Maven): affected from 25.0.0; fixed in 25.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-2741/ (Markdown: https://insights.sbomify.com/CVE-2026-2741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-2741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-2741
- OSV: https://osv.dev/vulnerability/CVE-2026-2741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-2741/
Summaries are generated and may contain mistakes; the official description above is the record.
