# CVE-2026-27448: pyOpenSSL allows TLS connection bypass via unhandled callback exception in set_tlsext_servername_callback

> Attackers can bypass TLS security checks if a custom server name callback raises an unhandled exception, allowing unauthorized connections.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2026
- **Updated:** 18 Mar 2026
- **Also known as:** AZL-80031, BELL-CVE-2026-27448, CLEANSTART-2026-FW34040, CLEANSTART-2026-KN51802, CLSA-2026-1776098295, CLSA-2026-1779181743, DEBIAN-CVE-2026-27448, ECHO-e106-5b29-8a6f, GHSA-vp96-hxj8-p424, MINI-7c2v-mw6g-qc7x, MINI-8cwf-jvr9-x4p2, MINI-c99x-fg92-c54q, MINI-h55p-fggr-8qm3, MINI-m573-8pgp-hqvh, MINI-p5pq-f5v5-pprm, MINI-vc69-jh75-c4p2, OESA-2026-1732, OESA-2026-1733, PYSEC-2026-2268, ROOT-APP-PYPI-CVE-2026-27448, SUSE-SU-2026:1416-1, SUSE-SU-2026:1582-1, SUSE-SU-2026:3424-1, UBUNTU-CVE-2026-27448, USN-8335-1

## What is CVE-2026-27448?

CVE-2026-27448 is a low-severity vulnerability in pyca pyopenssl, published on 17 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 0.14.0 and prior to version 26.0.0, if a user provided callback to `set_tlsext_servername_callback` raised an unhandled exception, this would result in a connection being accepted. If a user was relying on this callback for any security-sensitive behavior, this could allow bypassing it. Starting in version 26.0.0, unhandled exceptions now result in rejecting the connection.

Weakness: CWE-636 (Not Failing Securely)

## Which versions are affected by CVE-2026-27448?

3 open source packages ship an affected version, including pyopenssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyopenssl` | PyPI | From 0.14 | 26.0.0 |
| `pyopenssl` | PyPI | From 0.14.0 | 26.0.0 |
| `pyopenssl` | PyPI | From 0.14.0 | 26.0.0 |
| `python-pyOpenSSL` | SUSE:Linux Enterprise Micro 5.2 | All versions | 19.0.0-150300.3.3.1 |
| `python3-pyOpenSSL` | SUSE:Linux Enterprise Micro 5.3 | All versions | 21.0.0-150400.22.1 |
| `python3-pyOpenSSL` | SUSE:Linux Enterprise Micro 5.4 | All versions | 21.0.0-150400.22.1 |
| `python3-pyOpenSSL` | SUSE:Linux Enterprise Micro 5.5 | All versions | 21.0.0-150400.22.1 |
| `python3-pyOpenSSL` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 21.0.0-150400.22.1 |
| `python-pyOpenSSL` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 17.1.0-4.32.1 |

Products: Pyopenssl Pyopenssl.

## How do I fix CVE-2026-27448?

Upgrade pyopenssl to 26.0.0 or later.

## Is CVE-2026-27448 being exploited?

There is no known exploitation of CVE-2026-27448 in the wild and no public exploit code.

## Other vulnerabilities in pyca pyopenssl

- [CVE-2026-27459](https://insights.sbomify.com/CVE-2026-27459/): pyOpenSSL DTLS cookie callback buffer overflow (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-27448 and fix it if it is affected.

What it is: CVE-2026-27448 is a low-severity vulnerability in pyca pyopenssl, published on 17 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-27448 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyopenssl (PyPI): affected from 0.14; fixed in 26.0.0
- pyopenssl (PyPI): affected from 0.14.0; fixed in 26.0.0
- pyopenssl (PyPI): affected from 0.14.0; fixed in 26.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-27448/ (Markdown: https://insights.sbomify.com/CVE-2026-27448/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-27448
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-27448
- OSV: https://osv.dev/vulnerability/CVE-2026-27448

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-27448/
Summaries are generated and may contain mistakes; the official description above is the record.
