CVE-2026-27454 Discourse has check revision visibility on posts endpoint
Attackers can read hidden post revisions by enumerating version numbers due to missing authorization checks on the posts endpoint.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27454?
CVE-2026-27454 is a medium-severity missing authorization vulnerability in Discourse Discourse, published on 19 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, requesting /posts/:id.json?version=X bypassed authorization checks on post revisions. The display_post method called post.revert_to directly without verifying whether the revision was hidden or if the user had permission to view edit history. This meant hidden revisions (intentionally concealed by staff) could be read by any user by simply enumerating version numbers. Starting in versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, Discourse looks up the PostRevision and call guardian.ensure_can_see! before reverting, consistent with how the /posts/:id/revisions/:revision endpoint already authorizes access. No known workarounds are available.
Weakness: CWE-862
Which versions are affected by CVE-2026-27454?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.2, 2026.2.1, 2026.3.0 |
Products include Discourse Discourse.
How do I fix CVE-2026-27454?
Upgrade discourse to a fixed version for your release line: 2026.1.2, 2026.2.1 or 2026.3.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-27454 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27454 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-27454, GHSA-fq69-f929-wp96.