CVE-2026-27456 util-linux: TOCTOU Race Condition in util-linux mount(8) - Loop Device Setup
Local attackers can exploit a race condition in the SUID mount binary to read root-owned files or devices by replacing source paths with symlinks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-27456?
CVE-2026-27456 is a medium-severity vulnerability in util-linux, published on 3 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
util-linux is a random collection of Linux utilities. Prior to version 2.41.4, a TOCTOU (Time-of-Check-Time-of-Use) vulnerability has been identified in the SUID binary /usr/bin/mount from util-linux. The mount binary, when setting up loop devices, validates the source file path with user privileges via fork() + setuid() + realpath(), but subsequently re-canonicalizes and opens it with root privileges (euid=0) without verifying that the path has not been replaced between both operations. Neither O_NOFOLLOW, nor inode comparison, nor post-open fstat() are employed. This allows a local unprivileged user to replace the source file with a symlink pointing to any root-owned file or device during the race window, causing the SUID binary to open and mount it as root. Exploitation requires an /etc/fstab entry with user,loop options whose path points to a directory where the attacker has write permission, and that /usr/bin/mount has the SUID bit set (the default configuration on virtually all Linux distributions). The impact is unauthorized read access to root-protected files and block devices, including backup images, disk volumes, and any file containing a valid filesystem. This issue has been patched in version 2.41.4.
Which versions are affected by CVE-2026-27456?
It affects 1 product.
Linux distribution packages (22)
util-linux SUSE:Linux Enterprise Micro 5.3 | All versions | 2.37.2-150400.8.47.1 |
util-linux-systemd SUSE:Linux Enterprise Micro 5.3 | All versions | 2.37.2-150400.8.47.1 |
util-linux SUSE:Linux Enterprise Micro 5.4 | All versions | 2.37.2-150400.8.47.1 |
util-linux-systemd SUSE:Linux Enterprise Micro 5.4 | All versions | 2.37.2-150400.8.47.1 |
util-linux SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 2.40.4-150700.4.13.1 |
util-linux-systemd SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 2.40.4-150700.4.13.1 |
util-linux-systemd SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 2.40.4-150700.4.13.1 |
python-libmount SUSE:Linux Enterprise Server 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux SUSE:Linux Enterprise Server 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux-systemd SUSE:Linux Enterprise Server 16.0 | All versions | 2.41.1-160000.4.1 |
python-libmount SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.33.2-4.54.1 |
util-linux SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.33.2-4.54.1 |
util-linux-systemd SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.33.2-4.54.1 |
python-libmount SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux-systemd SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux SUSE:Linux Micro 6.2 | All versions | 2.41.1-160000.4.1 |
util-linux-systemd SUSE:Linux Micro 6.2 | All versions | 2.41.1-160000.4.1 |
python-libmount openSUSE:Leap 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux openSUSE:Leap 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux-systemd openSUSE:Leap 16.0 | All versions | 2.41.1-160000.4.1 |
util-linux openSUSE:Tumbleweed | All versions | 2.42-1.1 |
Products include Kernel Util-Linux.
How do I fix CVE-2026-27456?
Upgrade to a fixed version.
Is CVE-2026-27456 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27456 exists.
Other vulnerabilities in util-linux
Sources
Also known as ALPINE-CVE-2026-27456, AZL-81846, BELL-CVE-2026-27456, CLEANSTART-2026-ZQ21115, CLSA-2026-1782989143, DEBIAN-CVE-2026-27456 and 17 more.