CVE-2026-27458 LinkAce: Stored XSS in Atom Feed via CDATA Escape in List Description

High 8.7 Published Updated

Authenticated users can inject JavaScript into LinkAce list descriptions via Atom feed CDATA escape, leading to arbitrary code execution in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-27458?

CVE-2026-27458 is a high-severity cross-site scripting vulnerability in Kovah LinkAce, published on 21 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

LinkAce is a self-hosted archive to collect website links. Versions 2.4.2 and below have a Stored Cross-site Scripting vulnerability through the Atom feed endpoint for lists (/lists/feed). An authenticated user can inject a CDATA-breaking payload into a list description that escapes the XML CDATA section, injects a native SVG element into the Atom XML document, and executes arbitrary JavaScript directly in the browser when the feed URL is visited. No RSS reader or additional rendering context is required — the browser's native XML parser processes the injected SVG and fires the onload event handler. This vulnerability exists because the lists feed template outputs list descriptions using Blade's raw syntax ({!! !!}) without sanitization inside a CDATA block. The critical detail is that because the output sits inside <![CDATA[...]]>, an attacker can inject the sequence ]]> to close the CDATA section prematurely, then inject arbitrary XML/SVG elements that the browser parses and executes natively as part of the Atom document. This issue has been fixed in version 2.4.3.

Weakness: CWE-80

Which versions are affected by CVE-2026-27458?

It affects 1 product.

Products include Linkace Linkace.

How do I fix CVE-2026-27458?

No fix has been published for CVE-2026-27458 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-27458 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-27458 exists.

Sources

Also known as GHSA-2r9p-95xj-p583.

Is CVE-2026-27458 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free